iTerm requires a password to launch

Discussion in 'Mac Apps and Mac App Store' started by ivoryz, May 7, 2009.

  1. ivoryz macrumors newbie

    May 7, 2009
    Hi, I am in great need for suggestions.

    I got a new MacBook 13' yesterday. And in the first-time configuration, I set up an account with a short name which I would like to change minutes later. So following the thread at:, I set up a new account and switched my home directory.

    When I logged in using the new account, everything looked fine except and Both asked me for a password to launch. I gave them my admin password and they refused to take it! So I went to the keychain application, repaired my password in the First Aid. After that, Terminal could launch normally, but iTerm kept on asking for the mysterious password.

    I re-installed several times and restarted my MacBook several times. No use! One online thread suggested a substitution in the login shell, which I found is not human-readable (well, maybe partly readable).

    Any idea?
  2. sfinnie macrumors newbie

    Jul 22, 2009
    Need to update the Default Bookmark

    Just had this too, posting answer in case you're still suffering. You need to update the Default Bookmark:

    1. Start iTerm
    2. Click Bookmarks->Manage Bookmarks
    3. Change the 'Default' entry to match your new login:
      • Highlight the 'Default' entry in the table
      • Click the yellow pencil button at the bottom of the window to edit
      • Enter new username & working directory, e.g.
      • Command: login -fp ivoryz
      • Working Dir: /Users/ivoryz
      • Click OK
    4. Close Bookmarks window, quit & restart iterm

    Should work after that.

    - Scoot.

Share This Page