itouch 2g wireless connection problems

Discussion in 'iPod touch' started by no-ledge, May 20, 2009.

  1. no-ledge macrumors newbie

    Joined:
    May 20, 2009
    #1
    i've been searching the internet tirelessly for a solution to my problem for a couple of weeks now, and have yet to find a solution other than "it's a bug and apple won't fix it."

    so i decided to register here and see if the good people at macrumors have had any experience with this problem.

    i'm running a itouch 2g 8gig with firmware 2.2.1 (5h11a)

    the problem is this, when i first purchased my ipod touch, i could connect to both my neighbor and my schools wireless networks.
    i have no idea what the specs are on either my neighbors or schools wireless networks, i just know that they are both unsecured and lacking a password.

    the problem is, my itouch does not recognize that these networks even exist anymore.
    when i type all of the information by hand, it says "network not found", for both of the networks.
    i then tried going to my local staples, where there is free wifi for public use, and i use my laptop quite often and my itouch did not recognize the staples wireless network.

    what makes this problem even more confusing is the fact that all of the other people i know that purchased an itouch 2g seem to have exactly the same problem, after about a month and a half, their itouch doesn't recognize any non-secure wireless networks.
    and in yet another terribly strange twist, it recognizes secure wireless networks with no problems.

    also to be noted, itouch 1st generation has aboslutely no problems connecting to my neighbor, school, or staples wifi.

    any help would be greatly appreciated.
     
  2. upinflames900 macrumors 6502a

    upinflames900

    Joined:
    May 20, 2009
    #2
    give this a try

    I have an ipod touch 2nd generation as well, but i've never had this problem before. Did you try restoring the ipod using itunes? When you plug in the ipod to the computer, it is on the summary tab. Another think I was told was if you have a lot of apps on your ipod touch sometimes one of them can go awry causing your ipod touch to act up. You might want to try taking of any apps you have too. Unfortunately, that takes a lot of time and it is pain in the butt, but it might work. If that doesn't work do you still have it under warranty, because I would try taking it back. I'm sure they have wifi at every apple store, so it wouldn't be too hard to prove. Best of luck :eek:
     
  3. no-ledge thread starter macrumors newbie

    Joined:
    May 20, 2009
    #3
    thanks for the response!

    i've tried restoring it numerous times, to no avail.

    and i've also attempted taking off all of the applications and that didn't correct the problem either.

    today, while i was up at a friends, i was attempting to download some apps and every single app would download to about 10% then my itouch would lose wireless signal.
    the only way to fix that problem was to shut the itouch off, turn it back on, turn wireless back on and select renew lease, which would then cause it to work for about 10% more of the download then the same thing would happen.

    the problem seems to be fairly widespread in my area, so i find it really strange that there's no quick fixes on the internet for this.
     
  4. upinflames900 macrumors 6502a

    upinflames900

    Joined:
    May 20, 2009
    #4
    No problem, sorry it didn't work though. I would definitely try an apple store, if all of that didn't work. http://www.apple.com/retail/ that is the website to book a genius bar appointment if you are interested in trying that. They will at least look at it for free if you don't have it under warranty, but if it is a widespread issue then they may be no help. Sorry but I think that ends my knowledge of ipod touch unfortunately :(. Best of luck!
     

Share This Page