iTouch can't restore. MAJOR Problems!

Discussion in 'iPod touch' started by slomifier, Jul 25, 2008.

  1. slomifier macrumors regular

    Joined:
    Mar 25, 2008
    #1
    Macs really starting to tick me off.

    Today, my iPod started doing this weird BiOs thing, so I restored it (iPod side). When I pressed the restore button in iTunes, it told me some crap about needing to update to 2.0. I thought if it's saying that, surly that means they've made it free. I was wrong. $10, all the same. The download button on the left-hand sidebar failed to appear, so I tried to redownload it a few times to no avail. Finally, I went into the folder where I know the FWs download to, and sure enough, I saw a 2.0 FW file slowly growing. At least I knew it was downloading, but it would have bee nice if the download progress button was there. When I tried to load it, the bar got to like 95%, then a 6501 (I think thats the error code) error saying it failed. I removed iTunes, reinstalled it (as suggested by apple), and it still refuses to put 2.0 on my iTouch

    Any Help?

    (I'd like to JB it, so I tried downloading ZiPhone, but the download always fails, so if someone can give me a copy, it'd be much appreciated.)
     
  2. superman193 macrumors regular

    Joined:
    Apr 15, 2008
    #2

    PM sent, initiating help support.
     

Share This Page