iTouch jailbreak issue/stuck in DFU can't recover HELP?!?!

Discussion in 'iPod touch Hacks' started by hellomacguy, Oct 3, 2009.

  1. hellomacguy macrumors newbie

    Oct 3, 2009
    hey everyone I'v run into a bit of trouble with an itouch, here's my story.

    I recently bought a first gen itouch off ebay(I perfer the first gens physicle design, fits in my hand better). foolishly I decided to buy a untested one, expecting it to work fine. when it arrived it was in recovery mode. unfortunatly when I try to recover the ipod I get error 28,1604, and maybe one or two others. I believe the previous owners tried to jailbreak the ipod and something whent wrong. the ipod is now in DFU mode.

    I have tried numerous jailbreak apps(ifuntastic,INdependence,ZIPhone, etc)

    I ave tried restoring and jailbreaking on both win and mac but neither do anyting. I have tried shift+restore but this hasnt worked either. I just want this ipod to boot and run aps jailbroken or not. either way I'd be fine with it being jailbroken, I just want to make this thing work.

    can anbody help me?
  2. SeverinK macrumors newbie

    Jun 9, 2009
    Hey I had somewhat of the same problem just a couple hours ago I was trying to jailbreak my ipod touch 2G and it got stuck in DFU mode what i did was hold down the power and home buttons until the ipod reset itself, once it rebooted it displayed a blank white screen, so i rebooted on more time and POOF :eek:, fixed :)

    hope that helps;)

    lol im such a noob with all my emoticons

  3. jmann macrumors 604


    Dec 8, 2007
    bump on a log in a hole in the bottom of the sea
    Are you sure it is in DFU mode correctly? And what kind of IPSW did you try restoring it with? Like 3.1? 3.0? and was it jailbroken or non jailbroken firmware?

Share This Page