iTouch Restore

Discussion in 'iPod touch' started by Woch2331, Oct 14, 2010.

  1. Woch2331 macrumors member

    Joined:
    Jun 20, 2008
    #1
    My son just got an older iTouch back and went to restore it. All looks good, but the software version shows 2.2.1. When he goes to update, it says it's the current version. Then he goes to load an app, it says it requires a newer version? Issues? Options?
     
  2. eddy2099 macrumors member

    Joined:
    Sep 27, 2010
    #2
  3. Woch2331 thread starter macrumors member

    Joined:
    Jun 20, 2008
    #3
    Correct... found out it was a 1st Gen iTouch and 'can't' be upgrade past v3.1.3.

    But I did find this site: http://www.felixbruns.de/iPod/firmware/

    Downloaded the correct version. Completed another restore. Updated to v3.1.3. Loaded apps. Loaded music. Looks good!!
     

Share This Page