iTrip on my dock connector!

Discussion in 'iPod touch Accessories' started by Spock, Jun 29, 2009.

  1. Spock macrumors 68000

    Spock

    Joined:
    Jan 6, 2002
    Location:
    Vulcan
    #1
    So I just purchased a Griffin iTrip FM transmitter for my iPod Touch 1st Gen.
    Had a picture of it on the back and said it was compatible. I hooked it up and played music and after disconnecting it I have learned that it has somehow damaged my dock connector. It says Dock Connected any time I attempt to change the volume or do anything music or video related. Its an 8gb running 3.0 was working fine before I used the transmitter. I have tried to restore 3 times and still no luck, next Im going to attempt to downgrade it to 2.2.1 and see what that does I also intend on calling Griffin in the morning, If any one has any ideas or have had similar problem please let me know.
     
  2. bndoarn macrumors 6502a

    Joined:
    Mar 16, 2008
    #2
    on the 1g on 3.0 the you can't change the volume if no headphones are plugged in so the volume scrubber just doesn't show up. it's normal.
     
  3. Spock thread starter macrumors 68000

    Spock

    Joined:
    Jan 6, 2002
    Location:
    Vulcan
    #3
    Hooking headphones up does not make it work, thats how I found out the first time.
     
  4. wywern209 macrumors 65832

    wywern209

    Joined:
    Sep 7, 2008
    Location:
    do you rly want to know?
    #4
    try to restore the touch as going to apple won't do much as they don't cover for non-apple products.
     
  5. bndoarn macrumors 6502a

    Joined:
    Mar 16, 2008
    #5
    if it's still under warranty then just take it to apple and don't tell them you used the iTrip
     
  6. Spock thread starter macrumors 68000

    Spock

    Joined:
    Jan 6, 2002
    Location:
    Vulcan
    #6
    I wish it were still under warranty, oh well.
     

Share This Page