iTunes 10.01 and Firewall Issue

Discussion in 'Mac Apps and Mac App Store' started by Jony Mac, Nov 13, 2010.

  1. Jony Mac macrumors 6502

    Jony Mac

    Joined:
    Oct 27, 2010
    Location:
    Pittsburgh, PA
    #1
    Is anyone else having this issue? I've upgraded to iTunes 10.1 and every time I open it I get the following message. I've tried accepting multiple times and still no luck. I've removed the rule from the firewall settings, rebooted and opened iTunes again. Rebooted after I accepted a 2nd time and still no luck.

    I read on Apple's support site it could be due to having iLife '11 installed. Any ideas?

    [​IMG]
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Uninstall iTunes completely and reinstall it.
     
  3. medgirl2001 macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    USA
    #3
    I had the same problem. Very aggravating.

    I found a solution in this thread (10th post down I believe) on the Apple support site:
    http://discussions.apple.com/thread.jspa?threadID=2645811&start=0&tstart=0

    It sounds like there is something goofed up about the iTunes downloaded from the update server in that the firewall won't recognize it appropriately as an already signed app.

    I'm having the same problem with iPhoto '11 (v. 9.1) with sharing turned on, and unfortunately haven't found a fix for that yet, aside from turning off either sharing or the firewall.
     
  4. jude01 macrumors newbie

    Joined:
    Jan 27, 2009
    #4
    I had this same problem. There's no need to uninstall iTunes though, just download the new version from the Apple website and install it (it will overwrite the existing corrupt iTunes).

    PS. I don't think it has anything to do with iLife '11 as I've had this happen on previous versions of iTunes as well without iLife installed. Probably just a bad settings file or something.
     
  5. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #5
    Have any of you "hacked" iTunes to get the coloured icons back? I have and have seen elsewhere that it's this that causes the message.
     
  6. medgirl2001 macrumors regular

    Joined:
    Jan 11, 2009
    Location:
    USA
    #6
    I have not, and I don't think it has anything to do with that. I think this is a problem with the firewall not recognizing iTunes (and iPhoto) as signed apps.
     
  7. damson34 macrumors 6502

    Joined:
    Jul 18, 2002
    Location:
    Houston, TX
    #7
    I have gotten this throughout multiple iTunes updates. Annoying. I just drag the app to the trash and then re-install and it goes away.
     
  8. Dave Braine macrumors 68040

    Dave Braine

    Joined:
    Mar 19, 2008
    Location:
    Warrington, UK
    #8
    I shall give that a try then.
     
  9. damson34 macrumors 6502

    Joined:
    Jul 18, 2002
    Location:
    Houston, TX
    #9
    Hope it works.
     
  10. rxtiger macrumors member

    Joined:
    Oct 23, 2010
    #10
    Thanks!

    Had the same issue, reinstall worked like a charm. I appreciate the help!!:D
     

Share This Page