iTunes 10.4 trouble

Discussion in 'Mac OS X Lion (10.7)' started by mcapanelli, Jul 20, 2011.

  1. mcapanelli macrumors regular

    mcapanelli

    Joined:
    Aug 2, 2008
    Location:
    Whitestone, NY
    #1
    Hello all,

    I upgraded to lion today and now for whatever reason I can't complete the update to iTunes 10.4 I'm currently running 10.3.1 and can't seem to update. I keep getting an error message but no clear reason why. I keep my music on an external drive if this makes any difference. I'm running Lion on a late 2009 Macbook. Thanks in advance for any and all help
     
  2. aggerbo macrumors newbie

    Joined:
    Jul 21, 2011
    #2
    Same Problem

    I have the same problem, and I'm not using an external hard drive to store my music on. If you find a solution please post it here, I'm desperate...

    Lion hasn't really been a good experience for me, I can't use my mail.app either :( It doesn't show it self on startup and it's no where to be found :mad:
     
  3. mcapanelli thread starter macrumors regular

    mcapanelli

    Joined:
    Aug 2, 2008
    Location:
    Whitestone, NY
    #3
    That's weird. I'd guess there will be plenty of little anomolies that apple will have to deal with as the bugs in this system reveal themselves through real world use. For your mail.app you may have to reinstall it from your disk. I've had that issue in the past with snow leopard and that was the solution that worked for me.

    This iTunes thing is a strange one. The program still works fine, I just can't update it. To be fair iTunes has always been a little buggy for me, and my Lion experience, with the exception of this, has been very good.
     
  4. mcapanelli thread starter macrumors regular

    mcapanelli

    Joined:
    Aug 2, 2008
    Location:
    Whitestone, NY
    #4
    Here's a screen shot of the message I'm getting........

    [​IMG]

    That's not really giving me tons of info there is it.
     
  5. mcapanelli thread starter macrumors regular

    mcapanelli

    Joined:
    Aug 2, 2008
    Location:
    Whitestone, NY
    #5
    I'm bumping this to the top so it doesn't get lost in the shuffle.
     
  6. Bo98 macrumors member

    Joined:
    Jan 23, 2011
    Location:
    Shetland
    #6
    Are you using Apple's Software Update or did you download it from Apple's website?
     
  7. gmanist1000 macrumors 68030

    gmanist1000

    Joined:
    Sep 22, 2009
    #7
    I had this problem too. Reading through forums, I found a fix. Make another user account and make them an admin. From that account, do the Software Update, and this should work!

    Also when it is finished, you can delete the user and iTunes will still work just fine.
     
  8. mcapanelli thread starter macrumors regular

    mcapanelli

    Joined:
    Aug 2, 2008
    Location:
    Whitestone, NY
    #8
    I did both. When the update didn't work I downloaded it from the iTunes page.


    THAT SIR worked like a charm. Thanks man.
     
  9. gmanist1000 macrumors 68030

    gmanist1000

    Joined:
    Sep 22, 2009
    #9
    No problem!
     

Share This Page