iTunes 10.5 Error -42404/-42403

Discussion in 'Mac Basics and Help' started by Heisler98, Nov 14, 2011.

  1. Heisler98 macrumors member

    Joined:
    Oct 30, 2010
    #1
    Every time I've loaded iTunes 10.5, and now still iTunes 10.5.1, I get this error message: A required iTunes component is not installed. Please reinstall iTunes (-42403)

    I also get this error when I try to load the iTunes store: iTunes could not complete this Store Request: and it gives some error code (can't get it to reappear, happens randomly)

    I've tried reinstalling, messing around and deleting key plist files and preference documents, and I've even gone so far as to try to have the Apple Store geniuses (who, I must admit, aren't that genius---all they did was format the drive, back up in Time Machine, and put everything back...like that would help me at all), and fully erasing iTunes from my computer. I keep trying to reinstall, and nothing happens. If maybe iTunes would lend some help into WHICH component is missing...

    Any help, please? I can't sync my iPods and iPad, and there is data in my iTunes library to large for iCloud to handle. Please, constructive comments and replies only.

    Thanks!
     
  2. wrldwzrd89, Nov 15, 2011
    Last edited: Nov 15, 2011

    wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Usually the clue lies in Console. Have a look there - do a search for iTunes. It's in your Utilities folder - its primary purpose is viewing system log files.

    EDIT: I'd love to help decipher your logs. I have helped others with perplexing issues like this one that the logs revealed the cause of.
     
  3. Heisler98 thread starter macrumors member

    Joined:
    Oct 30, 2010
    #3
    My logs didn't reveal much (if by logs, you mean the "All Messages" option on the sidebar), and by searching iTunes it revealed even less. The only explanation for my error that I could come to was a Quartz Composer plug-in causing iTunes to crash, which happened yesterday, but didn't reappear earlier as far as I went back:

    Code:
    11/14/11 8:43:47 PM [0x0-0x31a31a].com.apple.iTunes:
    The plugin 'Quartz Composer Visualizer' failed to load because it has the wrong CPU architecture for this version of iTunes. (3585)
    This appeared twice in 15 minute intervals. But it didn't mention anything about the error that I'm receiving.

    Could you be more precise into which log files you want? Hopefully it is the one I'm attaching here, but let me know if you need something different.

    This is my system.log file. I'm also attaching the All Messages.log file, which should cover everything, I assume. They're in a zip folder.

    View attachment Log Files.zip
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    Thanks for that... wasn't terribly helpful though. I suggest reinstalling QuickTime 7.6.9, if you have Leopard. If you have Snow Leopard or Lion, though... I'm puzzled. I've not seen this message before.

    However, I do have some clues. It appears you've run a Mac cleaner program recently, based on what's in your logs. That's never a good idea - those tend to do more harm than good.
     
  5. Heisler98 thread starter macrumors member

    Joined:
    Oct 30, 2010
    #5
    I am running Lion 10.7.2, on a MBP mid-2010 13", Intel Core 2 Duo, 4 GB RAM. Tried reinstalling Quicktime, just to see if it would help. Unfortunately, it screwed it up to the point where it wouldn't play videos.

    The cleaner programs were only to get rid of the iTunes stuff I couldn't find. It didn't remove anything else, as far as I know. The problem happened when I updated to iTunes 10.5---it might have been something within the workings of the system, or the fact the arch changed to 64-bit. SOMETHING set off the error. I simply then went into Finder, did a search for iTunes with System files included, and deleted every developer file I found besides my own iTunes media. Then I installed iTunes again. Said the same error message. I can't sync my iDevices, and I hate to move my entire library over to my Windows computer, which I guess I'll have to do.

    Any other suggestions? Thanks for the help you've given, I appreciate it. :)
     
  6. bigjobby01 macrumors newbie

    Joined:
    Dec 23, 2011
    #6
    Any luck??

    Have you had any luck with solving the error -42404 issue? Im in the same position, I've put iTunes on my other PC and, after the iPad was wiped clean by my 1st PC, I connected it to the 2nd. It updated from iTunes store but all my purchased music, TV and films are missing. The apps were OK though????
     

Share This Page