iTunes 11.0.3 not seeing any of my devices

Discussion in 'Mac Apps and Mac App Store' started by notabadname, May 29, 2013.

  1. notabadname macrumors 65816

    notabadname

    Joined:
    Jan 4, 2010
    Location:
    Detroit Suburbs
    #1
    iTunes 11.0.3, since being installed 4 days ago, will not recognize any of my devices, 2 iPads, an iPod Touch, and 2iPhone 5s. I am running the most current version of 10.8 on my Mac Pro and iOS 6.1.4 on phones and 6.1.3 on other devices. I have powered down and relaunched everything multiple times and tried the devices on multiple user accounts with different USB ports, all,of which cause iPhoto to launch - so I know the connection is good.

    Has anyone else had this problem, and perhaps have a suggestion of how to remedy? Thanks.
     
  2. notabadname thread starter macrumors 65816

    notabadname

    Joined:
    Jan 4, 2010
    Location:
    Detroit Suburbs
    #2
    After working with Apple Tech support, the solution ended up being very simple: Download iTunes and reinstall. (as a note, iTunes can not be deleted (at least not easily) in OS 10.8, it will tell you it is required and may not be deleted. Just go to Apple.com and select "iTunes" from the top menu bar. And select the "Download iTunes" option. Then install it after the download is complete. Worked immediately. The Rep, a senior/supervisor, a level up from my first tech, sent the problem to engineering to determine if could be a repeatable problem/bug for others. It was iOS related, as only those type devices (2 iPads, 2 iPhones and an iPod Touch), and not my Nano or Classic, had a problem synching.
     

Share This Page