iTunes 11 Doesn't Work on Windows

Discussion in 'Windows, Linux & Others on the Mac' started by teknikal90, Nov 29, 2012.

  1. teknikal90 macrumors 68030

    teknikal90

    Joined:
    Jan 28, 2008
    Location:
    Vancouver, BC
    #1
    Hi all,

    bit of a problem.
    Today's iTunes update broke one of our computers! iTunes won't pop up and has the Windows Defender Shield on the icon. See below:
    [​IMG]

    I click on it, and it doesn't do anything (however, iTunes *32 is running in processes. In the screenshot above, I'd just killed them.) Tried to uninstall, reinstall, didn't work. I'm an admin user.
    The previous version of iTunes worked!

    Any tips?

    Thank you all in advance!

    p
     
  2. Shadow%20Mac macrumors 6502

    Joined:
    Dec 28, 2007
    Location:
    California
    #2
    Something went wrong with your installation. iTunes 11 for Windows is only available in 64bit, unless I am mistaken.
     
  3. teknikal90 thread starter macrumors 68030

    teknikal90

    Joined:
    Jan 28, 2008
    Location:
    Vancouver, BC
    #3
    that's probably it!
    how do I get a the itunes 32bit version?

    Thank you for the reply
     
  4. Phayz macrumors member

    Joined:
    Jul 9, 2010
    #4
    Try just going to the regular download site:

    http://www.apple.com/itunes/download/

    It should automatically detect you need the 32bit version and if available will offer you that as a download. I only have a 64bit version of windows so am unable to give you a direct download link
     
  5. Frozzie macrumors regular

    Joined:
    Jul 23, 2011
    #5
    It doesn't seem there is 32bit version at all from iTunes website.

    If your Windows is 32bit, I don't think you could have installed iTunes 11 in first place?
     

Share This Page