iTunes 12.0 using Yosemite... How do I delete...

dbrandt6

macrumors member
Original poster
Oct 28, 2007
63
2
Michigan
a Audiobook that shows up in iTunes? I've gone to my Music folder and deleted it from the Audiobooks folder, but it still shows up in iTunes. It was NOT purchased via iTunes but rather I added it myself. Thanks for your help!
 

BasicGreatGuy

macrumors G5
Sep 21, 2012
12,796
12,299
In the middle of several books.
I ran into the same problem recently, when I added several audiobooks to iTunes. I noticed that when I didn't use the "add to iTunes automatically" folder, the delete option was grayed out. I manually deleted the folder like you did, and ITunes still showed the book. I deleted the lts and library files and then used the auto add folder. Annoying problem solved.
 

dbrandt6

macrumors member
Original poster
Oct 28, 2007
63
2
Michigan
Control - Click does not do show delete at all in iTunes 12.0.0 on Yosemite.

----------

Ah Ha.... Option - Click did it! Thank you!
 

jbottrop

macrumors newbie
Oct 13, 2014
1
0
It has to be ALT+Rightclick. That brings up the Delete option in the context menu. Just solved the problem here.

EDIT: Oops, should've read your full post. I thought it's the signature under the "-----" ;-)
 

Scubadiver

macrumors member
Oct 25, 2007
75
30
Cutler Bay, Florida
Right Alt + right click will show the delete function, but you must keep holding down Right Alt when you select delete. :confused:

Somehow I doubt this was the intended function, but that appears to be the only way to actually remove an audio book.
 
Last edited:
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.