iTunes 12: Can't change Media Kind

Discussion in 'OS X Yosemite (10.10)' started by jakofharts7, Nov 4, 2014.

  1. jakofharts7 macrumors newbie

    Aug 14, 2010
    In iTunes 11, I was able to freely change the Media Kind on Music files. I would change it to Voice Memo to keep the files from uploading to ITunes Match to stay under the 25k song limit. However, in iTunes 12, the only option I'm given for Music files is Music. Anyone have any workarounds for this?
  2. Alimar macrumors 6502a


    Sep 17, 2014
    New York State
    Are you not seeing the 'Get Info > Options' in iTunes 12 on Yosemite...

    Attached Files:

  3. jakofharts7 thread starter macrumors newbie

    Aug 14, 2010
    No, I get that, but Music is the only option that shows up in the list for me. I don't have those other options. It's strange that you do.
  4. davehutch macrumors 6502a


    Mar 5, 2009
    Croxley, Herts
    To get the old interface, hold down 'Alt' as you click 'Get Info'
  5. jakofharts7 thread starter macrumors newbie

    Aug 14, 2010
    I figured this out. I had to turn off iTunes Match to be able to change the Media Kind. I don't recall having to do this in iTunes 11 but I could be wrong.
  6. rastriffler macrumors newbie

    Aug 8, 2008
    What about Movies/TV Shows

    I've turned off iTunes Match, but still cannot change media kind for any of the TV Shows or Movies showing up in Home Videos. It's incredibly frustrating, as it has scattered my movies and shows across Movies, TV Shows and Home Videos, seemingly randomly.

    Any help would be HUGELY appreciated, as this makes it a mess to find anything on the Apple TV.

    I've noticed that when I try to delete a TV show from Home Videos, then re-add it, it asks if I still want the video to be available in the cloud, which is weird, since iTunes Match is turned off. If it's in the cloud because I bought it through iTunes, I would expect that iTunes would know that it's a TV show.

  7. tinybeads macrumors newbie

    Dec 24, 2014
    can't change media kind using Windows and ITunes 12

    I'm using Windows 7 (sorry guys!), and can't access the Media Kind to correct it. On Nov 4, 2014, 08:11 PM #2 Alimar
    posted that it's possible to display the "old" Get Info display by holding down the Alt key on a Mac. Since I'm running Windows, the only key which allows me to display the old Get Info window is the Shift key. But the Media Kind function is still greyed out.
    I need to change the Media Kind from Home Video to Movie. At this time, I own all the videos (they are training videos). I have not purchased any videos through ITunes. NONE of my videos show up in the Movies library, so I cannot correct some information associated with each video.
    I've found an earlier version of ITunes but am reluctant to delete ITunes 12 so I can install it ... I have no idea what else that would mess up.
    I do not have ITunes Match turned on. None of my videos are set up as "read only."

    Help appreciated. Thanks!
  8. Peebz8 macrumors newbie

    Mar 28, 2015
    a solution?

    I think you'll find that you need to create an MP3 version (yes, if it's already an MP3 you will still need to recreate it) :eek:

    Then go to 'Songs' view and sort by date added, this should put the newly converted files to the top of the list. Hopefully you will be able to select all the files you have just converted, go to 'Get info' -> Options and from there select the file format you require. :cool:
  9. grafit macrumors newbie


    Dec 24, 2003
    Wales - UK
    Peebz8 solution worked for me, the others didn't. I am using the Mac Version of iTunes. It would seem once the track has been 'processed' by itunes, it doesn't like allowing you to change the media kind. Hence once you make a mp3 and then change it - Apple haven't had a chance to lock it.
  10. dalcorta macrumors newbie


    Aug 22, 2015
    chapel hill nc
    I recently ran into this when converting CDs to audiobooks after a long period of not doing it. In between I think I upgraded to iTunes 12/apple music and also loading the El Capitan Beta, so can't say which is the main culprit. Same issue, kind won't allow change from music to any other form- I also got an iCloud library sync error box. When I turned off iCloud music library option in the "general" tab of iTunes preferences (see below) I got back the option of changing the media type. When done I turn it back on. I hope this helps. Screen Shot 2015-08-22 at 7.29.31 PM.png

    Attached Files:

Share This Page