ITunes 7.3 Problems

Discussion in 'Mac Apps and Mac App Store' started by mrfrosty, Jun 29, 2007.

  1. mrfrosty macrumors 6502

    Joined:
    Oct 1, 2005
    #1
    Hi,

    Having just updated to ITunes 7.3 i'm getting the beach ball big time when it tries to update my library. If i delete my library and add songs back in again it adds for around 30 seconds then just freezes. I have removed all traces of It
    ITunes & re-installed 7.3 and things are still the same.

    Any ideas ?? The only other thing to mention is that my mini is at the moment suffering from the old snap crackle and pop problem....but i doubt its related.
     
  2. TheSpecialist macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    The Netherlands, Europe
    #2
    Hi,

    Afther reading the Macrumors news post about 7.3, I checked Apple Software Update, it spotted 7.3, downloaded, installed it. Then when I tried to open it first asked me if I agree with the EULA. Then it opens, starts doing things to my library, but works perfect. I'm using it now just like I used to and it sorts the music other then before. Albums starting with numbers are now in the back instead of the front. Also they sort differently with albums like, ''The Album'', it sorts on Album, not The. Also there is a different glow over the Playlists. But nevertheless, it works perfectly. I hope you get your problem solved mate.

    Btw this was on a Windows machine (lack of funds for a Mac)

    Goodbye.
     
  3. infz macrumors member

    infz

    Joined:
    Feb 25, 2007
    Location:
    Waterloo, Ontario
    #3
    *grumble* I wish iTunes would tell us these things before we software-update! The info dialog only talked about iPhone and appleTV.

    *grumble* IMO, numbers and special-characters should sort at the top.
     
  4. TheSpecialist macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    The Netherlands, Europe
    #4
    I kinda like it actually:rolleyes:
     
  5. nhborn57 macrumors newbie

    nhborn57

    Joined:
    May 30, 2007
    Location:
    New England
    #5
    iTunes 7.3 crashing!

    My system automatically installed iTunes 7.3 this morning and then iTunes proceeded to crash every time I tried to start it. Went to Apple's blog for iTunes and found out if you are running ShapeShifter, you must first close iTunes and then add iTunes to ShapeShifter Exclude List. Once you have done that, iTunes will start without the icon bouncing in the Dock. Any other problems, I would check out the Apple blog site.

    MacDeviant :apple:
     
  6. mrfrosty thread starter macrumors 6502

    Joined:
    Oct 1, 2005
    #6
    I have just done the same update on my G5 Imac downstairs......EXACTLY the same problem...So i'll give you some more detail.....

    All my music is stored on an Ubuntu Server with 2 USB disks attatched that rsync to each other overnight. The server is mounted from both mac's via the miracle of NFS. If i add the music from either mount it fails....If i copy the music locally it all adds just fine........so.......that all points to my server being a little screwed.........EXCEPT....if i roll back to ITunes 7.2 everything works just fine.........

    BUG, BIG ONE !!! There are also some rumblings on macfixit
     
  7. mrfrosty thread starter macrumors 6502

    Joined:
    Oct 1, 2005
    #7
    Do you have a link ? Ive never heard of that...
     
  8. dantidote macrumors member

    Joined:
    Jun 25, 2007
    #8
    Does anyone else notice that atrists that start with a number (2pac, 311, etc.) are now sorted AFTER the alphabet? So like (Yung Joc, ZZ Top, 2pac, 311...)
     
  9. Mainyehc macrumors 6502a

    Mainyehc

    Joined:
    Mar 14, 2004
    Location:
    Lisbon, Portugal
    #9
    Guys, this is a SERIOUS BUG which is affecting quite a few people!!

    Basically, iTunes becomes, for some reason, unable to write to the Library files, so each and every time it launches, it performs the "library updating" process. Also, it keeps nagging you with a somewhat self-explanatory error message, "The iTunes Library file could not be saved. An unknown error ocurred (-50)." (actually, now that I think about it, it's a tad cryptical, as "unknown" is not that precise :rolleyes: ).

    Check for yourselves on Apple Support Discussions... If this becomes widespread, it could seriously mar an otherwise flawless iPhone launch, while screwing a lot of (innocent, european ;) ) folks along the way :( .
     
  10. Mainyehc macrumors 6502a

    Mainyehc

    Joined:
    Mar 14, 2004
    Location:
    Lisbon, Portugal
    #10
    Now that you mention sorting, could someone please tell Apple to FIX THE F'IN PORTUGUESE SORTING BUGS AND TRANSLATION INCOHERENCES?
    Thanks.

    /rant
     
  11. rockosmodurnlif macrumors 65816

    rockosmodurnlif

    Joined:
    Apr 21, 2007
    Location:
    New York, NY
    #11
    Just something I have to get used to I guess. :(
     
  12. matthew24 macrumors 6502

    matthew24

    Joined:
    May 30, 2002
    Location:
    Netherlands
    #12
    7.3 has serious bug: Do not install !!

    I did have the error as well!:

    Solution given in discussionboard Apple:

    From the board:

    I have seemingly solved the problem. Having downloaded the old 7.2 version I thought I would try something before going through the contortions of uninstalling and reinstalling. So I exported my library file, then trashed the library file in the iTunes folder, then opened 7.3 and, on seeing that it was not giving me the error -50 message (as I had a brand new and empty library file) I then imported my old library file and, lo and behold, all seems to be working. At least no error messages - yet!
     
  13. pengu macrumors 6502a

    Joined:
    Mar 20, 2005
    Location:
    Diddily Daddily...
    #13
    Well as i mentioned in the thread about the itunes 7.3 release, i've had to completely re-create my library from the iTunes Library.xml file (i had to leave it running over night) because it would crash trying to load my existing library.

    anywho since this, it seems that randomly a heap of videos i had set as Music Videos and TV Shows were suddenly Movies again, and when i tried to "Get Info" on them, it would just do nothing.

    all i can think is that somehow itunes is giving very little importance to the embedded tags in the MP4 tags and instead reading from library files all the time. :(
     
  14. brettjohn macrumors member

    Joined:
    Apr 1, 2007
    Location:
    Australia
    #14
    thank you...this fixed my problem with the update

    mine was crashing after the install. i looked on the apple site for any help but guess i didn't search hard enough.

    you saved the day. cheers mate :cool:
     
  15. twofones macrumors newbie

    Joined:
    Jun 30, 2007
    #15
    appple's tunes blog?

    Do you have the URL for the blog above? Can find no help from Apple's support groups.
     
  16. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #16
    I don't seem to have any of the other issues, but I can also confirm that 'Pac is thugging the end of the list now. :( Which, I guess, is not such a big deal. Interestingly, the change also affected my Nano on sync to iTunes 7.3.
     
  17. g4paul macrumors newbie

    Joined:
    Jul 1, 2007
    #17
    iTunes 7.3 crashing stopped for me

    It took me a while for my iTunes 7.3 to stop crashing. I noticed when I was starting iTunes after upgrading it was attempting to levelize the volume of my podcasts - and was crashing in the middle of it.

    I brute forced my way through this by starting iTunes and after it had processed a few podcasts, I would click the (x) to stop it, then exit, restart iTunes, and repeat this process until it has processed all my podcasts. It has not crashed for me since. Hope this helps...at least before Apple fixes it.
     
  18. Heb1228 macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #18
    I'm having the same problem as well. I'll try exporting the library to see if that works for me. I think Apple's going to have to retract their Get A Mac tv ad with the PC's cryptic error messages.
     
  19. Pete in SJ macrumors newbie

    Joined:
    Jul 2, 2007
    #19
    iTunes 7.3

    Not being a Mac person, I dont know if this has been covered. My wife updated her computer this evening and installed iTunes 7.3 After the install, her Windows machine rebooted and horror of all horrors, her entire library and all the setting are gone. How do I return all her stuff? I'm not that familier with iTunes or other mac stuff.:confused:
     
  20. Nauset3TT macrumors newbie

    Joined:
    Jul 2, 2007
    #20
    THANK YOU. i'll do that in the morning, in the meantime i've reverted back to 7.2.
    although for this reason, i'm thinking of keeping it. oddly enough, Aimee Mann is sorted under A while Takagi Masakatsu is sorted under M.
    i would try a system restore.
     
  21. jinxnme macrumors newbie

    Joined:
    Jul 3, 2007
    #21
    re:itunes 7.3

    hey there i'm new to all this and have bin readin everything today...cause like the rest of you i had upgraded my itune...and was NOT a very happy camper!!!
    i'm not sure why MAC / IMAC offers these applications w/out gettin the bugs out..i'm in my fifties and didn't grow up round computers..it's all new to me, but i'm not stupid..i can read and have followed your instructions and..YES
    am now back at itunes 7.2 ...the ting that bugs me the most..this happened to me a few years back..w/the amount i payed for my old imac then the ipod and every program i have payed for tween there and now my new laptop...personally think owes me some compensation for my time!!! but seem like they are not lifting a finger to correct this....bugger them!!! lol:p
     
  22. jasonbrennan macrumors member

    Joined:
    Jul 12, 2006
    #22
    Does anyone have a link for iTunes 7.2? I'm not really crazy about 7.3 right now and I think I'll rollback...if it won't destroy my library...I'll just back it all up to be safe
     
  23. netmonkey macrumors newbie

    netmonkey

    Joined:
    Jan 31, 2005
    #24
    Hey, i had the same exact problem that started this thread. I didn't have anything fancy setup nor an iPod, and the only thing I had installed was divx/xvid/flip4mac...

    I looked everywhere online for fixing the problem. There were suggestions about deleting the plist file, but that would only work the first time I'd run iTunes and it didn't work....

    ...but I did have one video podcast, and when I saw that little x pop up, I clicked it and now iTunes has stopped freezing after those 30 seconds!
     
  24. TranceBeat macrumors newbie

    Joined:
    Jul 5, 2007
    #25
    ShapeShifter

    Yep Thnx For the info, but Also want to add, that if you close iTunes and remove it form the ExcludeList of ShapeShifter, the iTunes get the color back without problem, or at least it happened with me when did it. :D
     

Share This Page