iTunes 7.4.2 won't launch

Discussion in 'Mac Apps and Mac App Store' started by smartalco, Sep 26, 2007.

  1. smartalco macrumors newbie

    Joined:
    Sep 26, 2007
    #1
    I installed 7.4.2 probably a day or 2 after release, via Software Update, however, I now can't launch iTunes

    I have tried restarting, reinstalling, repairing permissions, removing preference files, and i managed to find a copy of 7.4.1 (although it was just the app, not the installer) and that won't launch either, the last time I repaired permissions (I have done it more then once throughout my frustrations) it came up with these fixes
    [​IMG]

    everyone other time i repaired permissions it had 100s if not 1000s (most or all related to itunes though)

    this is on a PB G4

    anyone have any ideas?
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    How far does it get before it doesn't launch? If that makes any sense. You can check Console to see if any messages are appearing there when you try to launch (just spotlight for console). That may offer some clues.
     
  3. smartalco thread starter macrumors newbie

    Joined:
    Sep 26, 2007
    #3
    i click it, it bounces once in the dock, the little arrow thingy appears, it stays there for about 2 seconds, then gives up

    and nothing in the console
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #4
    OK, see if you can find a log here, username/Library/Logs/CrashReporter/ which may have some error messages.

    This site also recommends deleting a certain package file before reinstalling iTunes. See it for details, http://www.ehmac.ca/mac-ipod-help-troubleshooting/50045-itunes-fails-launch.html
     
  5. smartalco thread starter macrumors newbie

    Joined:
    Sep 26, 2007
    #5
    no dice

    i then
    1. deleted /everything/ (plists, receipts, docs, the app, etc) itunes related that spotlight could find (aside from my library, which i renamed to random characters so in theory iTunes has no idea what it is)
    2. repaired disc permissions (nothing found)
    3. deleted the receipt for the apple mobile devices thing which is installed with itunes in the installer
    4. dl'd the 7.4.2 installer
    5. installed
    6. repaired disc permissions again (still nothing found)
    7. launched iTunes
    8. frowned :(

    still nothing in the console and no crash logs :/

    SUPER EDIT: ok, finally found the problem (or what i believe it to be), shapeshifter was making it crash, I'm downloading the latest version of shapeshifter now which says it 'Resolved an obscure issue that could cause applications to crash occasionally when ShapeShifter is loaded.', hopefully iTunes will run after update, if not, I just won't get to see my set theme on iTunes :/
     

Share This Page