iTunes 7.5 and Mac OS X 10.5.1

Discussion in 'macOS' started by JRomero, Nov 16, 2007.

  1. JRomero macrumors regular

    JRomero

    Joined:
    Jun 29, 2006
    #1
    Is anyone else experiencing issues with iTunes 7.5 and 10.5.1? When I open iTunes, it loads my library, and then after that, it just gives the spinning beach ball.

    Any clues on what might be wrong or what I need to do to fix this?

    Thank you for your help!
     
  2. iSaint macrumors 603

    iSaint

    Joined:
    May 26, 2004
    Location:
    South Mississippi y'all, near the water!
    #2
    Mine's been ok. You might look into reinstalling iTunes.
     
  3. aquajet macrumors 68020

    Joined:
    Feb 12, 2005
    Location:
    VA
    #3
    No need to start reinstalling things before trying more simple troubleshooting procedures first.

    I would try deleting all .plist files related to itunes. These are located in the Library:preferences folder within your home directory. Do a search for "itunes" and delete any file related to itunes with .plist in the name.

    You might also delete you itunes library database files in Music:iTunes in your home folder. These files are "iTunes Library" and "iTunes Music Library.xml".

    All of these files will be rebuilt when launching iTunes, but you will have to reconfigure your preferences and you will have to add all of your music back into your Library. Do this by first deselecting the "copy files to music folder when copying to library" option in iTunes preferences (under the advanced tab) to prevent duplicates being created. Then use "add to library" under the file menu to rebuild your music library.
     

Share This Page