iTunes 7.7 Issues - Solved

Discussion in 'Mac Apps and Mac App Store' started by monke, Jul 21, 2008.

  1. monke macrumors 65816

    monke

    Joined:
    May 30, 2005
    #1
    Info: iTunes 7.7, Mac OS X 10.4.11, Power PC

    For some reason, iTunes 7.7 has a problem. If I click on the Application icon, in the Library area, it automatically crashes or beach balls and doesn't respond. I have no idea why, and I've tried re-installing iTunes 3 times now without any luck.

    I figured there was something wrong earlier, but didn't really worry, because the icon is always messed up.
    Picture 7.png - Podcast Icon
    Picture 8.png - Purchased Icon
    picture 9.png - Audiobook top, Purchased bottom
    It's also looked like the Audiobook icon most of the time.


    Also, it may also be part of the problem, the Ringtones option is named as 'x' in Preferences for me.
    Picture 4.png - Without Ringtones
    Picture 5.png - With Ringtones

    Any ideas?
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    Throw away iTunes, and all preferences for it, the download and reinstall. Try it again. If you have an iPhone, call Apple and get some support from them, as you are covered.

    TEG
     
  3. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #3
    Where can I find the preferences?

    I don't have an iPhone, but rather an iPod Touch from a while back.
     
  4. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #4
    User/Library/Preferences/com.apple.iTunes(eyerything)
    /Library/Preferences/com.apple.iTunes(everything)

    If your iTunes library is not in the default location, you may have to change the iTunes preferences when you reinstall to point to that location.

    TEG
     
  5. Lynxpoint macrumors regular

    Lynxpoint

    Joined:
    Jan 13, 2005
    #5
    hello,

    i have the same "x" for ringtones. My problem has been I do not have an advanced preferences setting for iphone and ipod remotes. This is an issue as I can not get the iphone remote app to pair with itunes.

    I just used cleanapp to remove itunes and reinstalled, which did not fix the either of these problems. If reinstalling works for you please post everything you deleted.
     
  6. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #6
    Will try again!

    edit: I also don't have the Advance Preferences setting...

    I'll post back in this thread when something (hopefully good) happens.
     
  7. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #7
    It still doesn't work. :mad:

    Here's what I did:
    User/Library/Preferences/com.apple.iTunes(eyerything)
    com.apple.iTunes.eq.plist
    com.apple.iTunes.plist
    com.apple.iTunesHelper.plist

    /Library/Preferences/com.apple.iTunes(everything)
    wasn't anything there, deleted something earlier

    Applications/Utilities/Activity Monitor
    Force Quit iTunesHelper

    Empty Trash

    Download and install iTunes 7.7
    I used the 'Easy Install' method (it's default).

    One note, is that instead of it saying 'Install' on the button that installs it, it said 'Upgrade' so it means that there is still remains of iTunes on the system, right?

    I'm baffled. :confused:


    EDIT: Here's some more things I found out:
    If I click the 'iPod Games' preference check box, it shows up as 'Applications', still with the wrong icon.
    If I deselect it, it asks "Do you want to hide Applications?"

    Still baffled.
     
  8. Lynxpoint macrumors regular

    Lynxpoint

    Joined:
    Jan 13, 2005
    #8
    that is similar to what cleanapp did. It also deleted itunesaccess.pkg and itunesx.pkg from /library/receipts.

    When I reinstalled it did treat the install as new (going through license agreement, etc) but it is still broken so there must be something else involved. I thought it could be the Apple Mobile Device Support that itunes installs but the apple support page suggests reinstalling this only if the iphone is not recognized by itunes. For me the phone is recognized and syncs fine. It is just the remote app won't work and i have no remote app options where they are supposed to be.

    Very strange.
     
  9. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #9
    So your Applications tab works then? That's weird.
    I just don't understand it. I've re-installed, fresh re-installed, and nothing works... :(
     
  10. Lynxpoint macrumors regular

    Lynxpoint

    Joined:
    Jan 13, 2005
    #10
    yes, my apps tab works, the phone connects and syncs properly, etc.

    the only thing malfunctioning is the ability to use the phone as a remote.
     
  11. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #11
    I just tried doing the same process, except downgrading to iTunes 7.6.2 and 7.5, then upgrading to iTunes 7.7.

    Still have the same problem. Can't click on Applications, iTunes closes, and no option to use an iPhone or iPod Touch for a remote. :mad:
     
  12. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #12
    I decided to get fed up with iTunes until it worked. I opened iTunes, clicked 'Applications' and it would automatically close. Then it would bring up the "Report an Error to Apple" window with the choices "Close. Report. Reopen". I clicked Reopen, and did the same process 3 more times, until I was greeted with a different window. "iTunes has experienced an error." window appeared, with the options "Close. Try Again. Report". I clicked Try Again. iTunes gave me a Software User Agreement, went through the Setup again :)confused:) and opened, updated the Library. I noticed the 'Applications' tab was gone, so naturally I clicked on Preferences. I noticed the the Ringtones had no appeared, instead of 'x'. Checked the box for Applications, and it works (so far). Also, I now have the option for iPhone/iPod Touch remotes.

    I just quit iTunes to make sure that everything works when I reopen, and it asks if I want to keep the new settings or use original settings. I chose the new settings and it still works. :D


    Diagnosis:
    One of the first things I noticed was that the iTunes GUI reverted itself back to Aqua, and not the theme I had installed from Shapeshifter. I remember I had a problem back with iTunes 7.3 (or something like that) that I had to add iTunes to the exclude list of Shapeshifter in order for it to work.

    I'm not saying this will work, it just might be the source of the problem for some. :)
     
  13. Lynxpoint macrumors regular

    Lynxpoint

    Joined:
    Jan 13, 2005
    #13
    that is it! thank you!

    I added itunes to my shapeshifter exclude list and the "look for iphone and ipod touch remotes" appeared. After clicking "forget remotes" I was able to pair the phone to itunes and everything works.
     
  14. monke thread starter macrumors 65816

    monke

    Joined:
    May 30, 2005
    #14
    My diagnosis was right then, good.

    Glad to hear it's working for you. :)
     

Share This Page