iTunes 7.7 Sound Quality Problem

Discussion in 'Mac Apps and Mac App Store' started by Avatar74, Jul 14, 2008.

  1. Avatar74 macrumors 65816

    Avatar74

    Joined:
    Feb 5, 2007
    #1
    What's happening is that all audio playback in iTunes and Quicktime is sounding horribly mushy.

    I've had this problem before but the fix was simply removing third party plugins. Then the sound quality returned to normal. Nothing has changed with respect to my speakers, receiver, etc. Also, I am current on all software updates.

    One thing I haven't checked is this... I'm currently synching my iPhone. I haven't verified yet if the sound playback is normal while not synching. I would normally doubt this would be the problem but with many people reporting, including myself, that iPhone is taking a long time to synch to iTunes 7.7, I wonder if there aren't other things going funky during synch.

    But I don't have any third party plug-ins installed at this time. Any ideas on the problem and the fix?
     
  2. Oniko macrumors newbie

    Joined:
    Jul 16, 2008
    #2
    Same problem?

    I think I've got the same problem. The sound is very "tinny" and is present in headphones, external speakers & internal speakers. Just noticed a day or so after the upgrade but not sure if that is the cause.
     
  3. samwise666 macrumors newbie

    Joined:
    Jan 25, 2008
    #3
    i had this problem, sound was clipping and distorted

    download the itunes install again from the apple website and use the repair option.

    it fixed it for me.....
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  5. Fuchal macrumors 68020

    Joined:
    Sep 30, 2003
    #5
    Check preferences Playback tab and make sure Sound Enhancer and Sound Check are off.
     
  6. Oniko macrumors newbie

    Joined:
    Jul 16, 2008
    #6
    Mine is a 2.1 core duo Macbook running OSX. Sound Enhancer and Sound Check are off.
     
  7. Oniko macrumors newbie

    Joined:
    Jul 16, 2008
    #7
    Got it!

    Ok I figured out the problem, I had downloaded "HEAR" and I guess it left behind some settings when I trashed it (app zapper). Downloaded it again and used uninstaller and the sound is back to normal. Guess iTunes 7.7 is not to blame, just coincidence sorry.
     
  8. projectmayhem70 macrumors newbie

    Joined:
    Aug 28, 2008
    #8
    exact same issue

    I'm experiencing the same thing. poor, "treblely" sounding audio. my speaker volume is halfway up and it sounds like crap. i usualy only need it up to 1/3 of the way. the ONLY thing i did since the issue was i had itunes get artwork for titles it was missing on. i literally was listening to songs just before i did that, got a bunch of artwork, and the next time i went on, the audio was really poor.

    didnt touch any settings whatsoever. i tried downloading itunes again and running the repair option, and no good. tried both checking and unchecking sound enhancer and sound check.

    any suggestions???
     
  9. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #9
    maybe try re-installing? this shouldn't be... i got album artwork for my songs and the quality is the same.
     

Share This Page