iTunes 7.7

Discussion in 'Mac Apps and Mac App Store' started by Cyburnclassic, Jun 9, 2008.

  1. Cyburnclassic macrumors member

    Joined:
    Apr 21, 2008
    Location:
    Cambridge (UNI), London (Home)
    #1
    On the 3G iPhone site it says the minimum required is iTunes 7.7

    I see iTunes 8 aint coming out yet.
     
  2. Le Big Mac macrumors 68020

    Le Big Mac

    Joined:
    Jan 7, 2003
    Location:
    Washington, DC
    #2

    so what, other than 8 sounds "cooler" than 7.7?
     
  3. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #3
    MobileMe is also requiring 7.7

     
  4. jmmtn4aj macrumors member

    Joined:
    Feb 29, 2008
    Location:
    Singapore
    #4
    Jumping whole numbers usually denote bigger changes, interface improvements for example. I like new things every once in awhile :)
     
  5. Auzburner macrumors 65816

    Auzburner

    Joined:
    Apr 11, 2008
    Location:
    Syracuse, NY - USA
    #5
    right, so we should be seeing the new version 7.7 tommorrow. (Wednesday)
     
  6. kabunaru Guest

    Joined:
    Jan 28, 2008
    #6
    Or in "early" July. :p
     

Share This Page