iTunes 7.7

Discussion in 'iPhone' started by AceFernalld, Jul 9, 2008.

Thread Status:
Not open for further replies.
  1. AceFernalld macrumors 65816

    AceFernalld

    Joined:
    Mar 3, 2008
    Location:
    Massachusetts
    #1
    I greatly apologize if this has already been posted, and I did search, but I just came across this page on the MobileMe website:

    System Requirements

    Compatible device: Mac, PC, iPhone, or iPod touch.
    For Mac: Mac OS X v10.4.11 or latest version of Mac OS X Leopard; Safari 3, Firefox 2, or later.
    For PC: Windows Vista or Windows XP Home or Professional (SP2) or later; Internet Explorer 7, Safari 3, Firefox 2, or later. Microsoft Outlook 2003 or later recommended.
    For iPhone and iPod touch: 2.0 software.
    iTunes 7.7 or later (free download from www.itunes.com/download).
    Internet access with compatible ISP (broadband required for web applications); fees may apply.
    Some features require Mac OS X v10.5 and iLife ’08.

    So it says that iTunes 7.7 is actually a system requirement, and needed in order to install MobileMe. Doesn't that pretty much confirm that iTunes 7.7 will be out sometime today?

    Edit: Oh, sorry, I really did search, feel free to wasteland or close if needed.
     
  2. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
Thread Status:
Not open for further replies.

Share This Page