iTunes 7

Discussion in 'MacBook' started by jturn241, Sep 21, 2012.

  1. jturn241 macrumors member

    Joined:
    Mar 11, 2011
    #1
    My computer is running OS X 10.5.8. It will not let me update to the newest version of itunes so I can't update my iPhone. Is there a newer software I can install to allow me to do so?

    If so where can I download it?
     
  2. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #2
    What model/year is your Mac?
     
  3. jturn241 thread starter macrumors member

    Joined:
    Mar 11, 2011
  4. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #4
    You can phone Apple and order a copy of Snow Leopard (10.6) on DVD for $29

    1-800-MY-APPLE

    The latest iTunes (10.7) needs OS X 10.6.8 or greater to run. You should probably up the RAM in your MacBook to least 4GB as well.
     
  5. jturn241 thread starter macrumors member

    Joined:
    Mar 11, 2011
    #5
    It wont let me talk to a person without a $20 fee?
    So its going to cost me $20 just to be able to purchase the newer version?
    Can they help me at the apple store?
     
  6. flopticalcube macrumors G4

    flopticalcube

    Joined:
    Sep 7, 2006
    Location:
    In the velcro closure of America's Hat
    #6
    Perhaps. You could also try 1-800-676-2775. You need to get through to Phone Sales rather than support. I think the price of Snow Leopard has actually dropped to $20 now that I think about it.
     
  7. jturn241 thread starter macrumors member

    Joined:
    Mar 11, 2011
  8. chibiterasu macrumors 6502

    chibiterasu

    Joined:
    Apr 5, 2012
    Location:
    London, The United Kingdom
    #8
    The latest version of iTunes requires osx snow leopard (10.6) to run. So upgrade your os if your on an intel machine if your still on powerpc then you cant get the lastest version of iTunes.
     

Share This Page