iTunes 8 completely broke all my podcast functions!

Discussion in 'Mac Basics and Help' started by motulist, Sep 11, 2008.

  1. motulist macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #1
    Since updating to iTunes 8, now my podcast functions are all broken! New podcasts show up as available, but they all have an error exclamation point icon that says something like "you do not have sufficient access privileges, please check the URL." And the new podcasts that had already downloaded in itunes 7 before I updated to 8, when I plug in my ipod and click sync it doesn't send those podcasts over! And even when I manually drag those new podcasts onto my ipod icon in itunes it give the (+) icon indicating that if I drop it on then the podcasts will copy over as its supposed to, but when I let go to drop it on to the ipod it does nothing!

    What the **** man! I wanted only one thing from itunes 8 - better performance and better functionality for the features that already existed, instead I got the opposite. The only thumbs up I can give to the new itunes is that it launches a bit faster (though it's still much slower than it should be.)

    Aaaaanyway, does anyone know how I can fix this? Or do I just have to wait for Apple to release a bug fix?
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    This might make your head explode but I'm going to suggest repairing disk permissions. You might want to try reinstalling iTunes 8 as well using the manual download.

    Don't forget to hop over to the Apple Support Discussion boards as well.
     
  3. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #3
    Just to be sure I tried repairing permissions, but it didn't work. The error message doesn't make it sound like a disk permission problem, if the error message is at all accurate and not just a sort of catch-all error message for any random podcast error, then it makes it sound like a network permissions problem on the podcasts server not allowing me to access their podcast directory through itunes 8. But that couldn't be possible because it doesn't sound like everyone using itunes 8 is having this same problem.

    EDIT: or maybe iTunes 8 somehow is getting its outgoing network connection requests rejected by OS X locally? Man, what the heck dude.
     

    Attached Files:

  4. motulist thread starter macrumors 601

    motulist

    Joined:
    Dec 2, 2003
    #4
    Ah... I fixed the problem. My itunes library and itunes downloads folder are on a disk networked from my other computer. I changed OS X's folder permission on the downloads folder so it's set to 'anyone can read and write" and that fixed the problem. Apparently itunes 7 had no problem writing to the download folder with the permissions it has always had, but for whatever reason itunes 8 is now sensitive to permission settings on the downloads folder.

    Whatever, problem solved.
     

Share This Page