iTunes 9.1 goes to account screen on app update

Discussion in 'iOS Apps' started by RobT, Apr 3, 2010.

  1. RobT macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #1
    Ever since i updated to SL 10.6.3 and iTunes 9.1 every time I download app updates for my iPhone it goes to my account info. screen first.

    The scenario is that I check for app updates in iTunes, I find there are like 3 of them. I hit the download free updates button and get the box to enter my password. Then, instead of downloading the updated apps, the screen goes to my account screen, the one where you can edit your payment info, change password, etc. Anyway to fix this so it stops going to the account screen?

    Anyone else having this issue?
    TIA

    --Rob
     
  2. LoganT macrumors 68020

    Joined:
    Jan 9, 2007
    #2
    The same exact thing has been happening to me too. I think it might have something to do with the new TOS for iTunes. I think it's supposed to bring you to a EULA that you are supposed to Agree/Disagree too. But, it's obviously not doing that.
     
  3. zepfhyr macrumors newbie

    Joined:
    Dec 13, 2009
    #3
    I, too, am having this problem. So far, I haven't found a solution beyond immediately re-downloading the apps after clicking "Done" before the cookie for staying signed in to the iTunes Store timed out.
     
  4. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    I had the same thing happen to me. It was an issue with the new EULA users had to accept. They screwed up the redirect, but it began working eventually.
     
  5. Kahnyl macrumors 68000

    Joined:
    Feb 2, 2009
    #5
    I tried something earlier. I clicked the update all button and it asked me to login to my account settings. I cancelled and then clicked the individual app update buttons instead. I wasn't asked to login, the updates downloaded, but I did get an error (5002) telling me my store request could not blah blah. The error didn't effect anything though, I just got it for each update I downloaded.

    There's definitely some messed up linking going on.
     
  6. bunnyhero macrumors newbie

    bunnyhero

    Joined:
    Nov 4, 2008
    #6
    same thing happening to me, with iTunes 9.1 and windows XP.

    i did the individual app update thing too, and got the same errors, but the updates still occurred fine.


    i tried something different just now. i quit and relaunched iTunes. then i went to iTunes store, and clicked on account info. i clicked on "terms of service" link (which opened in browser). then i went to apps, check for updates, and 'download all updates'. they all downloaded without error.

    i have no idea if all of those steps are necessary or not, or if the problem will resurface next time there are app updates, but i thought i'd share anyway.
     
  7. hsotnicam8002 macrumors 6502

    hsotnicam8002

    Joined:
    Mar 13, 2008
    Location:
    United Kingdom
    #7
    I have this problem too and posted it on versiontracker but no-one else there has posted a reply. I had the same problem a couple of versions ago and it's returned! Roll on 9.1.1! :(
     
  8. mtehonica macrumors regular

    Joined:
    Nov 7, 2007
    #8
    I am having the same exact problem. Just started happening after updating iTunes. Haven't found a fix yet. :(
     
  9. sassenach74 macrumors 65816

    sassenach74

    Joined:
    May 3, 2008
    Location:
    Hampshire, England
    #9
    And there's me thinking I was doing somethingwrong 'cos this is happening to me every time I update an app(s) via iTunes....weirdness.
     
  10. ajobes macrumors newbie

    Joined:
    Aug 31, 2009
    #10
    Exactly the same problem here since the recent updates - VERY annoying!! :confused:
     
  11. hawaiipoolman macrumors regular

    Joined:
    Nov 5, 2007
    #11
    I had the same issue. Here is the fix, you need to goto Store and unauthorize your computer then reauthorize it. 8)
     
  12. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #12
    Gave that a try but it didn't work to resolve the problem for me.
     
  13. JustLeft macrumors 6502

    Joined:
    Sep 20, 2007
    #13
    Deauthorize/authorize didn't work for me either. Still have the issue.

     
  14. Goatbert macrumors newbie

    Joined:
    Mar 13, 2005
  15. aibo macrumors 6502

    Joined:
    Jan 17, 2008
    Location:
    Southern California
  16. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #16
    It's odd because it was happening then quit for a while and now it's back to doing it again.:confused:
     
  17. Kevenly macrumors regular

    Kevenly

    Joined:
    Nov 22, 2008
    Location:
    The wrong planet.
    #17
    I have been having this problem for months and it is driving me nuts! It's just awful. It doesn't just happen with app updates anymore either, it happens constantly. I have tried EVERYTHING from complete iTunes de-installs, to account de-auth and re-auth, to changing every possible setting, editing all my account data, confirming the terms of service changes.. Everything.. And here is how it goes.

    I have to have items in my download queue. Things download normally until a a certain amount of time has passed. Let's say I pause the downloads for a while, 30 minutes or so, when I go to resume it happens. If something takes a while to download, perhaps the same amount of time or more passes as when I pause it, it happens too. And here is what happens.

    First a small white window will come up saying Accessing iTunes Store, then the status window at the top of the main iTunes window will say the same thing, then it will quickly switch to "Checking for available downloads", and instantly the account name/password window will pop up. I then type in my name and password and after a brief moment it comes up AGAIN, then it it goes to the Account screen. It then immediately brings up the login window AGAIN. Then I click done, and it exits the screen, asks for my login twice more, then says the download failed with a -8003 error. Then it goes back to the account screen, asking me for the password twice more. It does this until it goes through every item lined up in my queue, then it stops until I attempt to resume downloads again.

    If I simply quit out of iTunes all my downloads automatically begin without having to enter anything, but after a certain amount of time.. 30 minutes or so, it all begins again.

    As well as every possible manipulation of the software and account settings, I have also tried running on various different networks in different locations and none of it matters, it happens regardless.

    It started with 9.0 and persists into 9.1.1

    I'm on 10.4.11 on TiBook G4.
     
  18. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #18
    As of Saturday (5/22/10), now getting a "1004" error instead of the payment/profile screen. Any ideas?
     
  19. psywzrd macrumors 68030

    Joined:
    Feb 6, 2008
    #19
    Same thing is happening to me now too. So annoying!
     
  20. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #20
    I'm getting the 1004 error too, only when downloading app updates (purchasing new apps has been fine). Happening for a week or so - really annoying. After dismissing the error, a second click will proceed to download my updates.
     
  21. chari macrumors newbie

    Joined:
    Jun 8, 2010
    #21
    I'm also getting the 1004 error every updating.
    Do you have any information the problem will be resolved or not , if we used iTune9.2.
    It will be released within two weeks.

    I'm on SL and iTune 9.1.1 with Japanese environment.
     
  22. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #22

    iTunes 9.2 beta still has the "1004" error
     
  23. chari macrumors newbie

    Joined:
    Jun 8, 2010
    #23
    Thank you, RobT.
    So the problem will continue..

    By the way, My Mac does not report error 1004 in recent 2 days.
    Now I got error 5002 when I update the Apps for all. then click again,
    Updating process is success without any problem.

    I don't know what is happened, and why problem is changed...
     
  24. hsotnicam8002 macrumors 6502

    hsotnicam8002

    Joined:
    Mar 13, 2008
    Location:
    United Kingdom
    #24
    The problem has resolved itself! I haven't changed anything so I assume it was at the Apple server end.
     
  25. RobT thread starter macrumors 6502a

    RobT

    Joined:
    Dec 20, 2007
    Location:
    Ohio, USA
    #25
    Same with me too. The last two days or so, now its a "5002" error.
     

Share This Page