iTunes 9 MiniPlayer Mode

Discussion in 'Mac Apps and Mac App Store' started by Burnsey, Sep 9, 2009.

  1. Burnsey macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #1
    It used to be you clicked the green (+) at the top and it would switch to miniplayer mode, now for some reason mine does not do that, it just resizes iTunes. This is very annoying, anyone else experience this? Anyone know how to make it switch to miniplayer mode when you click the green (+) at the top?
     
  2. MattZani macrumors 68030

    MattZani

    Joined:
    Apr 20, 2008
    Location:
    UK
  3. Burnsey thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #3
    ahh thanks! Is this new in iTunes 9?
     
  4. haiggy macrumors 65816

    Joined:
    Aug 20, 2003
    Location:
    Ontario, Canada
  5. MadGoat macrumors 65816

    MadGoat

    Joined:
    Jul 30, 2007
    Location:
    Canada
    #5
    For me, I'm actually happy they changed that.

    It didn't follow the design standards of other apple applications and trying to maximize itunes and accidentally clicking what should be a maximize button only to make it smaller annoyed me.
     
  6. j-a-x macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas
    #6
    Can anybody explain to me why when I click the green button it just sort of offsets my iTUnes window to the right and under my dock a bit? It doesn't seem to matter whether the iTunes window is large or small or where it is on the screen. When I click the green dot it just offsets it to the right and under my dock. Why would I want a button that used to minimize iTunes now just put it partially under my dock instead? Is this only affecting me? I recorded a video of it. I'll post it if I can find somewhere to host it.
     
  7. j-a-x macrumors 65816

    j-a-x

    Joined:
    Apr 15, 2005
    Location:
    Houston, Texas
    #7
    This site kinda sucks but here's my video of me attempting to use the green button with a regular click. I understand that an option-click will give you the old behavior of the green button back but I don't understand why a regular click doesn't do anything useful.

    http://www.filefactory.com/file/ah7g63d/n/iTunesGreen_mov
     
  8. Daschund macrumors member

    Joined:
    Sep 16, 2003
    Location:
    New York Citeeeeeeyyyy!
    #8
    Yeah, same thing here. I didn't realize that the Option+Click made it work, but to me it is still a step into the wrong direction. I understand that it didn't go with the rest of the apps on the way it worked before, but that's because the rest of the apps don't have a mini-player. To make such a widely used resource (clicking on the green button) a two click thing (or press+click thing) is a step in the wrong direction IMO. I wrote to Apple (iTunes>Provide iTunes Feedback) complaining about it, perhaps if enough people complain about it they will make it go back to the way it was before. :)
     
  9. jettredmont macrumors 68030

    Joined:
    Jul 25, 2002
    #9
    The green "Zoom" button has always meant to toggle between "make the window as big as it needs to be" and "make the window the last size the user adjusted it to".

    The problem with iTunes (which really isn't unique to iTunes, by the way) is that there are multiple "as big as it needs to be" sizes. If you are looking at the list of all songs, some would contend that miniview isn't at all "as big as it needs to be" because all that information is removed from the screen.

    That having been said, I like just about everyone else was a major user of the green zoom button to get to mini viewer mode. It'll take some time before I'm comfortable option-clicking the green arrow to do what I'm used to it doing with no option.

    On the other hand, option-click has a major bug: mini viewer now always goes back to the center of my f*cking screen instead of remembering its last position (unobtrusively off in corner) and going there instead. Which is, of course, the most unlikely spot for it to be useful. Both shortcuts (option-click and View|Switch to Mini Player/command-shift-M) do the same thing here.

    Odd that I hadn't noticed that last night. I wonder if something I did today, like using the Home Sharing feature, triggered it?

    Update: Restarted my Mac (just restarting iTunes didn't do it) and now the miniplayer remembers where I put it. Odd. But, at least, now it's better. I suspect somehow it got its prefs file locked up while I ws playing around with settings and couldn't write the window position of the miniplayer to disk.
     
  10. CallsignBaron macrumors member

    Joined:
    Apr 17, 2007
    Location:
    NC USA
    #10
    I was a little ticked off when I clicked the green min/max button and didn't go to the mini player. I use that all the time. Option+click does work but it's a pain, mine does however go to the lower corner of my screen like I had it. I hope they change it, it shouldn't be too hard to at least give the option to return to the previous behavior. Feedback sent!
     
  11. co.ag.2005 macrumors 65816

    co.ag.2005

    Joined:
    Jun 17, 2009
    Location:
    Fort Worth, TX
    #11
    for me, I used the keyboard shortcut for mini player... command+ctrl+z went to mini player... now, Apple has changed it to be command+shift+m

    very annoying. now I have to get used to a new keyboard combo :(
     
  12. OriginalFormula macrumors regular

    Joined:
    Apr 14, 2009
    #12

    I didn't even know there was a keyboard shortcut (but probably should have figured there was). Thanks for the tip!
     
  13. TimSHB macrumors newbie

    TimSHB

    Joined:
    Nov 14, 2008
    Location:
    KCMO
    #13
    It's awkward trying to type commmand+shift+m with one hand. The old shortcut is much easier.
     
  14. Burnsey thread starter macrumors 6502a

    Joined:
    Jul 1, 2007
    Location:
    Canada
    #14
    I've been trying to live with the option click (+) but it's just too much of a pain, I find myself clicking the (+) out of habit expecting the miniplayer and just getting an annoying and pointless resize. Why do they have to ruin stuff like this?
     
  15. co.ag.2005 macrumors 65816

    co.ag.2005

    Joined:
    Jun 17, 2009
    Location:
    Fort Worth, TX
    #15
    No problem!

    I agree 100%!
     
  16. jettredmont macrumors 68030

    Joined:
    Jul 25, 2002
    #16
    Haven't tried, but I'd bet a dollar if you went into the OS Keyboard prefs you'd find that you can change the shortcut to the one you are used to if it's really a major issue. Personally, I avoid doing this as I switch between enough Macs that having non-standard keyboard shortcuts on one really just ends up defeating the whole purpose, but if you're just working on one Mac there's no reason you couldn't just change those shortcuts around to fit your particular preferences.
     
  17. raea macrumors newbie

    Joined:
    Sep 25, 2009
    #17
    For the Idiot PC user :)

    I am one of the idiot PC users, so anyone else using a PC please don't take offense.... There are many like me and this info could be helpful. :D

    The Command key that all of you are discussing is not available on my HP Pavilion PC Notebook keyboard.

    It took me just a bit to figure that out, because I too was having a major problem switching OUT of mini-player view.

    So as an FYI to the PC users, the cmd key is our fn key on an HP keyboard.

    Hope this was helpful, as the info on how to switch between them was helpful to me. I switched to mini-player mode and lost the little icons on the left side to restore it to full view player. So when I substituted the fn key (Cntr + fn + M), I was able to switch.

    Thanks so much everyone!

    Oh, and if this is in this forum already or in another, I am sorry to post already known info. It's just that when I went searching for help on the site I was unable to find help. A google search led me here...

    Thanks again! ;)
     

Share This Page