itunes 9 truncated characters on windows

Discussion in 'Mac Apps and Mac App Store' started by stevep314, Feb 16, 2010.

  1. stevep314 macrumors newbie

    Joined:
    Feb 16, 2010
    #1
    itunes 9 truncated characters on windows.

    Ok so we have a big library of .wav files. We discovered that itunes has been truncating song names and album names.

    eg:

    Elvis Presley:

    [Disc 2] The Complete '68 Comeback Speci

    When My Blue Moon Turns To Gold Agai.wav



    Seems to be a problem only on windows. As on the mac you can have as many characters as you want, so it seems.

    Also because of truncating it now sometimes sees double tracks and adds a number to the end! While it could have been a remix or something...

    eg:

    Baby, What You Want Me To Do 1.wav
    Baby, What You Want Me To Do 2.wav
    Baby, What You Want Me To Do 3.wav
    Baby, What You Want Me To Do.wav



    We also had the track number adding problem, but we were able to fix this using this:

    There used to be an option in iTunes that let you decide whether or not you wanted to import the track numbers along with the CD’s that you import. That option is no longer in the software. Using this trick though, you can disable track numbers again.

    1. Hold down the Windows key and press R.

    2. Type %appdata% and click OK.

    3. Open the Apple Computer folder.

    4. Open the iTunes folder.

    5. Open the iTunesPrefs.xml file using Wordpad.

    6. Scroll down to the User Preferences section. There should be a couple of lines that say:

    <key>User Preferences</key>
    <dict>

    7. Below that line, type in the following:

    <key>create-filenames-with-tracknumber</key>
    <data>
    AA==
    </data>

    8. Save and close the iTunesPrefs.xml file. iTunes will no longer import track numbers on your imported CD’s now.

    Oh yeah! :

    It’s important to mark the iTunesPrefs.xml as “read-only” to make this trick work!
    Making the file Read Only prevents iTunes from reverting the file to the previous setting.


    Any ideas?

    Thanks,

    Steve
     
  2. stevep314 thread starter macrumors newbie

    Joined:
    Feb 16, 2010
    #2
    On the mac

    On the mac i was able to add a file like this:

    [​IMG]

    maybe character limit is 255 UTF-16 ?

    Thanks,

    Steve
     

Share This Page