Itunes -9813 Error - No Root Certificate

Discussion in 'Mac Apps and Mac App Store' started by Stephen S, Mar 19, 2005.

  1. Stephen S macrumors newbie

    Mar 19, 2005
    Alright, I need someone smarter than me to give me some help!
    Below, is everything that I know...

    I'm on a G4 laptop, running 10.3.8 and iTunes 4.7.1
    I'm connected through a Motorola SURFboard SB5100 with cable, no router beyond that

    My problem popped up approx. 4-5 weeks ago. I'm not sure exactly when, or what I did to cause it. But I think I updated to 10.3.8 from 10.3.7 around that time.

    Whenever, I click "Buy Song" or "Sign-In" in iTunes, i get this error:
    "iTunes could not connect to the Music Store.
    An unknown error occurred (-9813)"

    • I can browse the iTunes Music Store and listen to samples
    • I can access CDDB
    • I have been downloading songs successfully since iTunes was created
    • I can play previously purchased songs
    • I can visit secure websites without trouble
    • I have a second computer (iMac DV) running 10.3.5, and it connects to my iTunes account, and downloads songs without problem.
    • I have Norton Personal Firewall on my computer, but I have disabled it recently, just to make sure (either way, I was downloading songs successfully with the firewall in Stealth Mode, without problem for a year)

    • I cannot purchase songs or sign-in to my account, as of 4-5 weeks ago, from my laptop.
    • Periodically, Safari tells me that the site I'm visiting cannot be authenticated, and may not be secure

    By definition, a -9813 Error is:
    errSSLNoRootCert - No root certificate for the certificate chain.

    I have read in many forums, where people get similar error text, but with a 502 Error. From what I can tell, that is simply a busy system usage error that goes away if you try again later. I've actually had that error sporatically over the last few years without trouble. This is more in line with the 29294/9812 errors. It will not go away... it's different.

    From the research I've been able to do, everything points to SSL Certificates. Unfortunately, I don't really know anything about these.

    • Checked my Date&Time settings
    • I have removed iTunes (and all associated libs, prefs, folders, receipts, etc...) off of my computer, and reinstalled 4.7.1 without eliminating the problem.
    • I used disk repair to check verify and correct premissions
    • I also looked into my Keychains (X509Certificates & X509Anchors) I replaced these with the 10.3.5 Cert & Anchor files from the iMac, without eliminating the problem, so I put the original Cert & Anchor files back into the Keychains folder.
    • I tried Scooter Magrooter's DNS fix without success <>
    • Firewall / No Firewall... didn't make a difference
    • SysPrefs/Network/Proxies - all of that was unclicked

    This problem seems to be very specific to secure connections between my laptop and iTunes... I really think it has something to do with Certificates (mainly because the error's definition states that I don't have a 'root certificate'), but I'm lost as to how that can be fixed.

    Thanks in advance for any help you can give me!
  2. Stephen S thread starter macrumors newbie

    Mar 19, 2005
    ** FIXED **

    After much trouble, with Apple and my computer... I have a solution that worked, so I'm posting it for all to learn from.

    If you are running 10.3.8, and ever get a -9813 Error or need to restore your root certificate settings, here is the solution:

    • Go to Applications>Utilities>Keychain Access
    • From the dropdown menu, select Window>Keychain First Aid
    • Select the "options" button
    • From the General Tab, select "Reset My Keychain"

    This will revert your keychain to the factory default settings, and giving a fresh 'root certificate'

    Done... no thanks to Apple.
  3. Thatoneguy2 macrumors member

    Dec 12, 2007
    Not a solution for me, anyone else have suggestions?

Share This Page