iTunes always asks for permission

Discussion in 'OS X Mountain Lion (10.8)' started by digitalfailure, Jan 28, 2013.

  1. digitalfailure macrumors regular

    Joined:
    Sep 24, 2012
    #1
    How can I stop the pop up window asking for permission to connect from appearing everytime I open iTunes on my new iMac?

    In the firewall settings iTunes is showing as green to connect to the outside world.

    All the info I can find ends up deleting iTunes, surely there's an easier way :confused:
     
  2. tzus macrumors member

    Joined:
    Aug 18, 2008
    Location:
    UK
    #2
    I have exactly the same problem. Help would be appreciated.
     
  3. syrinxx macrumors member

    Joined:
    Nov 7, 2011
    #3
    had the same problem

    i found out not cleaning the chache or what ever in safari solves this problem.
    i did a reset every day after work in safari and had this problem. forgot to do it one day and found the solution for the password problem...

    it was the same in 10.7.X

    greets
     
  4. forza69 macrumors 6502a

    forza69

    Joined:
    Jan 30, 2010
    Location:
    San Diego, CA
    #4
    “Do you want the application iTunes.app to accept incoming network connections?”

    Do this -

    Open a new Finder window, press Command-Shift-G, and type the following directory path:

    /Library/Preferences/

    now locate the file named com.apple.alf.plist and delete it. Reboot.

    Problem fixed.

     
  5. tzus macrumors member

    Joined:
    Aug 18, 2008
    Location:
    UK
    #5

    Thank you. Sounds good to me and so far so good. :)
     
  6. digitalfailure thread starter macrumors regular

    Joined:
    Sep 24, 2012
    #6
    I found and deleted that file before restarting as detailed.

    I thought all was well when I opened iTunes as the box didn't pop up. Looking deeper into this, I opened the firewall screen to see if apple was still on the lidt to find that the firewall was turned off since the reboot.....it was on when i deleted the file for sure.

    Turned on the firewall again and iTunes now asks permission every time it starts. Other software that needs to connect for updates etc aren't asking :confused:
     
  7. Spikeywan macrumors 6502

    Joined:
    Dec 11, 2012
    #7
    All deleting the file does is turn the firewall off.

    I rang the Apple Support Line about this a couple of weeks ago, and they told me to...

    Turn the firewall off!! :rolleyes:

    For those that don't know, it's System Preferences -> Security & Privacy -> Turn Off Firewall

    I asked about the lack of security as a result of turning it off, and was told not to worry. She's had the firewall off for years and never had a problem or virus.

    Personally for the amount of hassle clicking on 'Allow' when you start iTunes causes, I think having the firewall on is worth it.

    Also, you could just close iTunes with the red x, rather than quitting it, and you won't see the dialogue box.
     
  8. digitalfailure thread starter macrumors regular

    Joined:
    Sep 24, 2012
    #8
    Is there any chance of apple doing a fix for this?
     
  9. tzus macrumors member

    Joined:
    Aug 18, 2008
    Location:
    UK
    #9
    Tim Cook's email address is: tcook@apple.com ;)
     
  10. turtlez macrumors 6502a

    turtlez

    Joined:
    Jun 17, 2012
    #10
    Seems to happen if you have 'Remove all website data' checked in the safari reset window. I unchecked it and now I never get the password request in iTunes.
     
  11. tzus macrumors member

    Joined:
    Aug 18, 2008
    Location:
    UK
    #11
    Having looked around for solutions, and there seem to be many that work for some and not others, I decided to try the one solution that seemed to work across the board; deleting and reinstalling iTunes. It seems to have done the trick, and iTunes actually seems more responsive.

    To delete iTunes I followed the following advice:

    Deleting iTunes is not recommended unless you know what you’re doing.

    Launch Terminal from the Utilities folder within Applications and type the following commands:

    cd /Applications/

    This brings you into the Applications directory, the next command deletes iTunes itself:

    sudo rm -rf iTunes.app/

    Enter the Administrator password to confirm. There is no warning or confirmation and iTunes will immediately be deleted, effectively uninstalling it from the Mac.

    Deleting the iTunes application will not delete the iTunes library or music, and any purchases bought through iTunes will still remain tied to the Apple ID used to originally buy them.

    You can then download the newest version directly from http://www.apple.com/itunes/download/ and running their installer will bring iTunes back to life on your computer.
     
  12. turtlez macrumors 6502a

    turtlez

    Joined:
    Jun 17, 2012
    #12
    I'd have to say this is the most fail proof way. Reason being is my solution was for my previous computer and it worked but on my new 2012 iMac, I am clearing all checked boxes in the Safari reset and not having to enter my password in for iTunes (which fixed the issue before). Fresh install of the OS or iTunes is without doubt the best way to go.
     
  13. Mike MA macrumors 65816

    Mike MA

    Joined:
    Sep 21, 2012
    #13
    Did it that way two weeks ago and can confirm that things do work well since than - compared to switching off the firewall this is a painfull but safe procedure. Still can't believe the Apple support really said something like this as above been stated....
     
  14. digitalfailure thread starter macrumors regular

    Joined:
    Sep 24, 2012
  15. BigNavy505 macrumors newbie

    Joined:
    Jan 30, 2013
    Location:
    New Mexico
    #15
    This is the only thing that worked for me last night after trying the following:

    1. Removing the firewall plist file
    2. Removing the iTunes entry from the firewall settings

    -------------


    https://discussions.apple.com/thread/2087017?start=60&tstart=0

    PortableGenius Southern Hemisphere
    Currently Being Moderated
    Re: "Do you want iTunes to accept incoming network connections?"
    Nov 16, 2011 2:59 PM (in response to Glenn Carter)
    I think I have solved the problem using these steps:


    SITUATION: I was using Mac OS X 10.6.8 Snow Leopard and I upgraded it to Mac OS X 10.7 Lion and I start experiencing the "iTunes network connection" issue. I updated it to Mac OS X 10.7.1 (the issue is still there), and then I updated to Mac OS X 10.7.2 (unfortunately, the issue is still there. So here's what I did.


    1 - DELETE iTunes

    Quit iTunes
    Navigate to /Applications and locate iTunes app
    Select iTunes and hit Command+i to “Get Info” on the application
    Click on the Arrow next to “Sharing & Permissions” to reveal the access panel
    Click on the lock icon and authenticate with your administrator password
    Under “Privilege” set both instances of “everyone” to “Read & Write”
    Close out the Get Info window and drag iTunes to the Trash, and then empty the trash

    REFERENCE: http://osxdaily.com/2011/09/13/delete-itunes-in-mac-os-x-10-7-lion/


    At this point, I suggest restarting your Mac. You can skip restarting but just to be sure, restart.


    2 - INSTALL iTunes

    Download iTunes (The current latest version 10.5.1 is available http://support.apple.com/kb/DL1426
    Install it

    And that's it. I opened iTunes and the issue is gone.
     
  16. Spikeywan macrumors 6502

    Joined:
    Dec 11, 2012
    #16
    Every chance. In fact if you update to 11.0.2 (26), you'll get a nice surprise. :)
     

Share This Page