iTunes always asks to allow incoming connections

Discussion in 'macOS' started by Ruahrc, Jul 5, 2009.

  1. Ruahrc macrumors 65816

    Joined:
    Jun 9, 2009
    #1
    I have this wierd problem on my MBP. Every time I launch iTunes it asks me if I want to allow incoming network connections. It asks this because I have configured my firewall settings to "Set Access for specific services and applications". The catch is, iTunes is already listed in the list of apps, and is configured to "allow incoming connections".

    So then why is it asking me every time to allow? It only happens to iTunes, other apps are in the list and do not ask me this every time I launch them.

    Anyone else have this problem, and know of a fix?

    Ruahrc
     
  2. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #2
    I have this same problem. Haven't found a fix yet, but really haven't looked into it much either since I leave iTunes open most of the time anyway.
     
  3. Dae macrumors regular

    Dae

    Joined:
    Apr 30, 2009
  4. TwoBytes macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #4
    same problem.

    i tried going into the firewall, removing itunes, restarting computer but i still get this message.

    any fixes?
     
  5. qubex macrumors 6502

    qubex

    Joined:
    May 12, 2004
    Location:
    045°042'21.99"N, 009°005'056.57"E
  6. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
    #6
    The only fix I've found to this is to turn off the firewall and allow all incoming connections, which I realize is a terrible way to deal with this annoying problem.
     
  7. rwilliams macrumors 68040

    rwilliams

    Joined:
    Apr 8, 2009
    Location:
    Durham, NC
  8. TwoBytes macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #8
    thanks, this worked from that thread. Creds to the chap:


    Launch iTunes and click "Allow" when you see the alert box.
    Open iTunes Preferences.
    Click on "Devices".
    Uncheck "Look for iPhone and iPod touch Remotes".
    Then click "Forget All Remotes".
    Close iTunes Preferences.
    Quit iTunes.

    Now relaunch iTunes and see if you are asked to allow incoming network connections again. If it has stopped, and you must use a remote, then try re-pairing the remote again and see if the alert appears again
     
  9. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #9
    The 10.5.8 update seemed to fix this for me. I just kept ignoring it and then noticed the alert no longer comes up anymore after updating.
     

Share This Page