iTunes: An unknown error occurred -42408

Discussion in 'Mac Apps and Mac App Store' started by iPowers, Dec 1, 2012.

  1. iPowers, Dec 1, 2012
    Last edited: Dec 1, 2012

    iPowers macrumors 6502

    Dec 23, 2006
    Ok so Software Update told me to upgrade to iTunes 11 and I did, not realizing how different the new layout is and I wanted to go back. So, I followed the directions for downgrading it back to iTunes 10.7. It worked, but the problem is that I kept getting this error:

    An unknown error occurred -42408

    I would get this error everytime i start iTunes

    At first I really didn't think it'd be an issue because iTunes still worked fine for me and the errors i saw it for people were regarding the iTunes store and I never really use the iTunes store, BUT, when I delete a song, it ALWAYS asks me whether to keep the file in the itunes media folder or to delete it, and when I delete a song it doesn't do that anymore, so I really want to fix this issues.

    Does anyone know how to get rid of it?

    Update: It also claims that my iPod is broken when my computer says it works fine.
  2. JackButler, Dec 1, 2012
    Last edited: Dec 1, 2012

    JackButler macrumors member

    Feb 3, 2008
    re-installed iTunes 10.7 using Pacifist (if it asks to Replace or Update on files, you want to replace). Revert to your previous library file (iTunes Library.itl)... also run disk utility and repair permissions after that.
  3. iPowers thread starter macrumors 6502

    Dec 23, 2006
    I tried doing that, but what would Pacifist do and how would it make a difference in my situation.

    I did disk utility and revert to the previous library file. and that didn't do anything.
  4. chrfr macrumors 604

    Jul 11, 2009
    The Apple installer won't replace newer files, while Pacifist will allow this. That will solve your problem.
  5. JackButler macrumors member

    Feb 3, 2008
    That is correct, so remember in Pacifist to click Replace and not Update. I got back to iTunes 10.7 with no problems.
  6. AJTEX macrumors newbie

    Jan 11, 2011
    This was the ONLY solution that helped on this issue regarding reverting back to v. after installing the HORRIBLE iTunes 11!
    I THANK YOU so much for this post on installing "Pacifist" and then re-installing v.10.7.... and "Replacing" every file etc.

    This really was the only solution!!!
  7. bone1990 macrumors newbie

    Dec 3, 2012
    Hi, I have the same problem!! Now I have iTunes 10.7 but when I open it say "An unknown error occurred (–42408)"

    Can you explain me the complete procedure for use Pacifis?

  8. JackButler macrumors member

    Feb 3, 2008
    1. Mount the iTunes 10.7 dmg
    2. Launch Pacifist
    3. Click Open Package and navigate to "Install iTunes" package in the mounted dmg. Pacifist will open it and you will see it's contents in a window.
    4. Click on the first item in the list "Contents of Install iTunes" to select it.
    4. Click the Install arrow in the top right menu bar of Pacifist.
    5. It should prompt you for PW
    6. From there on it will install, and you just need to click Replace when prompted (replace or update).

    I recommend checking and repairing permissions afterwards with Disk Utility.
  9. iPowers thread starter macrumors 6502

    Dec 23, 2006
    Awesome!! I got it to work. Thank you so much guys. :)
  10. Phildo macrumors member


    Nov 14, 2011
    Perth, Western Australia
    - Installed latest iTunes.
    - It's ugly. Hugely ugly.
    - No worries, retrieve backup iTunes library from Time Capsule.
    - Keep getting iTunes 042408 error.
    - More unsuccessful attempts at getting around this.
    - Starting to panic. Nothing left on Apple TV to watch.
    - More unsuccessful attempts.
    - Nervous fidgeting. End of the world is nigh.
    - Google search.
    - Come across this thread.
    - It works. iTunes 10 lives!

    T h a n k y o u ! ! !



  11. tornjeans macrumors newbie

    Dec 4, 2012
  12. finepiks macrumors member

    Dec 5, 2012
    Brilliant, many thanks. Now happily back to 10.7 where I will be staying. My version of 11.0 was continuously crashing after being open for 5 mins or so but just sitting idle. After the tenth time the only way was back!! I don't know how to read crash logs but it seems to have something to do with the audio codecs.

    However, as others have mentioned, crashing apart - the GUI is astonishingly bad for an Apple product. The interface is something I was more used to from freeware windows programs! The new ideas are nice but the look just sucks. Is this what we have to expect from Apple now that Steve is dead? First it was iOS6 and now this!!
  13. thebigbunny macrumors newbie

    Dec 6, 2012
    I got excited, did all this and now I'm stuck.

    I'm getting the newer version "iTunes Library.itl" error.

    Not sure where I went wrong but I see other mention of "iTunes Library.itl" in this thread ... just not what to do.

    Your help is appreciated! Thanks.
  14. thebigbunny macrumors newbie

    Dec 6, 2012
    "Revert to your previous library file (iTunes Library.itl)"


    How do I do that?

    Does that depend on running the permissions in Disk Utility"

    I'm in a holding pattern here.

    I'll just stop for now.
  15. mackandproud macrumors 6502

    Jun 9, 2008
    Yup, exactly where I'm at. I feel like I've wasted enough time on this POS.
  16. thebigbunny macrumors newbie

    Dec 6, 2012
    WAIT! I got it, I got it, I got it!

    You need to replace that "iTunes Library.itl" file with the old one (and it *is* there on your computer — see below).

    Follow these instructions:


    Close iTunes

    Go to your iTunes folder

    It's either under:

    - My Documents\My Music\iTunes\

    - \Users\username\Music\iTunes\

    (Make sure that it's right one by looking at the Time & Date of the FIle (should be the same, as the last time you closed itunes)

    Drag the iTunes Library file from the above location to the Desktop.

    Open the Previous iTunes Libraries folder in the iTunes folder.

    Locate the file named iTunes Library YYYY-MM-DD where YYYY-MM-DD is the date you upgraded iTunes (Year-Month-Day).

    Drag this file to the iTunes folder (the enclosing folder).

    Rename this file to iTunes Library.

    Open iTunes.


    That worked for me! Good luck.
  17. mackandproud macrumors 6502

    Jun 9, 2008
    I may or may not try this. There's really no reason to go through all of this garbage. Someone needs to get fired at apple for this travesty.
  18. no-idea macrumors newbie

    Dec 6, 2012
    Still stuck on error (-42408)

    I've tried all the suggestions in this thread but still get the error (-42408).

    When I ran Pacifist, I got a lot of pop up boxes telling me files couldn't be moved because they could not be modified. I don't know what that means.

    Also, after running Pacifist on the iTunes 10.7 dmg, the version of iTunes that opens on my system is 10.6.3 which I pulled from TimeMachine to start this process.

    Any idea?
  19. finepiks macrumors member

    Dec 5, 2012
    Initially I was unable to remove iTunes 11 as an error message would pop up saying it cannot be removed as it's needed by the OS, dragging it into App Cleaner didn't work either. So I clicked Get Info and noticed there was a "custom" rule at the top of the permissions list. So I simply changed all the permissions to Read & Write and was then able to manually delete it.

    Then I downloaded a fresh 10.7 dmg (google and you'll find it) and ran that with Pacifist. Select "Open Package" then the Install arrow at the top left of Pacifist. Click "replace" with all the pop ups that appear. Then replace the .itl file with the .itl file from the "Previous Libraries" folder and finally run Disk Utility and select "Repair Permissions". You'll see a lot of files the DU changes permissions on and mine took around 5 minutes to complete.

    I had to do this as initially I'd just tried re-installing from the 10.7 DMG without Pacifist and was getting the same (-42408) error messages.
  20. mackandproud macrumors 6502

    Jun 9, 2008
    Yeah but you really shouldn't have to do all that to cover apple's a--. It's not like they had to rush out 11; they've had many years of practice so this turd is completely inexcusable.

    I expect bloated, non-intuitive garbage like this from windoze. I guess apple is becoming another microsoft.
  21. no-idea macrumors newbie

    Dec 6, 2012
    didn't work for me

    I've done all of this and still get the (-42408) error.
  22. mackandproud macrumors 6502

    Jun 9, 2008
    I've attempted to reinstall 10 at least 3X using all of the steps listed in this thread, without success.

    It really should be apple's responsibility to provide some method of reverting to previous software in these types of instances.

    I don't feel comfortable with terminal hacks which could brick the OS to get back to 10.

    I don't know what good complaining here will do, but I've rarely had cause to complain about mac programs, so this stands out as a rare exception.

    I'm cautiously optimistic that apple will modify itunes significantly in the next few weeks but I'm just p*ssed that a formerly reliable piece of software is now such a piece of trash.
  23. JackButler macrumors member

    Feb 3, 2008
    You can use AppCleaner (I did that myself) but you have to go into it's preferences and un-tick "Protected default apps" (I would re protect after your done). Do not allow it to trash the user/music/itunes folder if that shows in the list (this is where your iTunes data and library/s reside).

    no-idea, not sure how to help you since you first went back to iTunes 10.6.3. This reinstall works for 10.7 since it was the last version apple released before v11 of iTunes and some system files maybe different between 10.6.3 & 10.7.
  24. finepiks macrumors member

    Dec 5, 2012
    Ah, should have known that - thanks.
  25. dldnh macrumors newbie

    Sep 12, 2006
    Thank you!!

    Thanks for this information and thanks for Pacifist! I read somewhere that it's nagware. It's not, it's software, and you should pay for it. It definitely saved me $20 of headache!!

Share This Page