iTunes and App Store reviews page not loading correctly

Discussion in 'iPhone Tips, Help and Troubleshooting' started by SFTifoso, May 25, 2011.

  1. SFTifoso macrumors newbie

    Joined:
    May 25, 2011
    #1
    I have a 16GB iPhone 4 that I bought about 2 months ago. The problem I'm having is that when I try to read the reviews page for apps, songs, movies etc. it doesn't load the reviews. I tried loading the reviews in both my wifi network and Verizon's 3G network, but that seems to make no difference. I also tried restarting, hard restarting, restoring, and restoring to factory defaults (which sucked cause I lost all my game saves and spread sheets), but still didn't solve the issue. Could this be a defective phone? I tried googling and can't find anybody else having this problem. BTW this only happens about 10% of the time, but it's still very annoying.

    Here are some screen shots I took of the problem.

    [​IMG]

    [​IMG]
     
  2. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #2
    It's most likely a sporadic glitch on Apple's end, not yours. I'm seeing it at the moment (10:50 PM PST on 5/25) on two iPhone 4's, one JB'd on 4.2.1, one non JB'd on 4.3.2, and on a non JB’d iPad on 4.3.3. So it's not likely a firmware reset or a hardware exchange is going to fix things.
     
  3. maliu macrumors 6502a

    Joined:
    Jun 24, 2010
    #3
    Happened to me a couple of days ago. Weird. The first time I've had that happen. Unfortunately I have nothing else to add exept that you aren't alone :)
     

Share This Page