iTunes and iMovie butting heads...

Discussion in 'Digital Video' started by wdogmedia, Aug 16, 2007.

  1. wdogmedia macrumors member

    Joined:
    Oct 12, 2004
    Location:
    Kirkland, WA
    #1
    My mom has been working on an iMovie project for her dad's upcoming 80th birthday; she bought a whole bunch of music from the 1930s and the 1940s on iTunes to use, but has been having some DRM issues that I can't quite seem to figure out....

    She's only used 3 out of her 5 authorizations, but for some reason she can't export her iMovie project without getting an error dialog saying that her computer is not authorized to play some of her iTunes music contained in the timeline. I can throw the whole project on an external HD and can reproduce this error on all three of her authorized machines, but if I create a new iMovie project from scratch and use some of the same music, I don't get the error....

    The same music on the same computer plays without incident in iTunes and in the iMovie project timeline....any ideas?
     
  2. ppc_michael Guest

    ppc_michael

    Joined:
    Apr 26, 2005
    Location:
    Los Angeles, CA
    #2
    I'm pretty sure that DRM'd iTunes music cannot be used in iMovie, but someone should verify this because I haven't actually tried it.
     
  3. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #3
    maybe you could remove the DRM security thingo and then retry using it???
     
  4. skimaxpower Guest

    Joined:
    Jan 13, 2006
    #4
    Luckily, your mom has two easy options. This is a 10-minute fix.

    Option #1: Burn the songs onto a CD (as allowed with iTunes purchases) and then rip the CD back onto the computer through iTunes. Your best bet is to switch the iTunes preferences to rip to .aiff format. This will make iMovie happier.

    Option #2: Download a shareware program called Audio Hijack to 'hijack' the audio as you play it real-time through iTunes. Then import the resulting .aiff file into iMovie.

    Good luck
     
  5. skimaxpower Guest

    Joined:
    Jan 13, 2006
    #5
    PS: note to Apple, this stuff is why I still buy music on CDs and not ITMS
     
  6. stevechollet macrumors newbie

    Joined:
    Aug 17, 2007
    #6
    A friend had this same problem and we resolved it. It is a problem with the preference file for iMovie.

    This is not related to DRM or any of that. iTunes files should all play in iMovie on your computer.

    Here is the solution:

    1. Find this file on your system: "com.apple.iMovie.plist"
    It will be in a preferences folder. You may have more than one on your system (system, users, etc).

    2. Move this file (all copies of it) to the trash.

    3. Start iMovie.

    iMovie will create a new, uncorrupted preference file. You should then be able to use all of your downloaded iTunes music with no issue.
     
  7. evil_santa macrumors 6502a

    evil_santa

    Joined:
    Sep 23, 2003
    Location:
    London, England
    #7
    +1
     
  8. Texas04 macrumors 6502a

    Texas04

    Joined:
    Jul 2, 2005
    Location:
    Texas
    #8
    +2

    CD's are a MUCH higher quality as well. (When you rip them)
     
  9. MichaelPA macrumors newbie

    Joined:
    Sep 1, 2007
    #9
    One thing that I tried (and it worked) was to open the iMovie file by alt-clicking it and selecting "show Package Contents". From here I opened the media folder and deleted the problem audio file. When I open the iMovie project next time an error message came up informing me that an audiio file was missing. I ckicked 'ok' and the project opened. I was then able to import the audio file from iTunes without the error message.
     
  10. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #10
    I haven't had any problems with iTunes purchases in the latest iMovie '08.

    Just for what it's worth ;)

    -Kevin
     
  11. jleeskahen macrumors newbie

    Joined:
    Jul 8, 2008
    #11
    In a recent movie project that students at my school were working on, we had this crop up a couple of times. Each time the music that had been purchased had not been played through to the end of the song before being inserted in iMovie.

    Before noticing that I had tried removing the song from the package and re-importing it, only to have the same problem occur. I'd also pulled plist files, and eventually I just burned and re-imported as mp3s to get around the problem.

    Since then, we had another project come through with the same symptom but happening in iPhoto when trying to make a slideshow. We pulled the songs from the slideshow, played the end of the songs in iTunes so the "Last Played" column had an entry. After that, we didn't have any authorization problems.

    That is the only time I've been able to test it, if the problem comes up again, I'll try that and re-post if it works again, or if it doesn't work!
     

Share This Page