itunes and iphone stuck in authorization loop

Discussion in 'iPod' started by kddpop, Jan 15, 2009.

  1. kddpop macrumors regular

    Jan 5, 2006
    oklahoma city, ok
    i will be as detailed as possible while trying to remain brief:
    my superdrive was not properly mounting/playing dvd's so i took my macbook in to the genius bar. they replaced my optical drive. when i got it home, the picture on my display was all messed up. i took it immediately back to the apple store, and they acknowledged the problem, said the video cable had been damaged in the earlier repair. i left it with them over night. when i got it back the next morning, all seemed to work just fine. they have replaced the video cable and the logic board.
    watched a dvd and then went to sync my iphone. i am now stuck in this loop:
    the iphone backs up and syncs contacts, mail, etc. then when it gets to the music, i get this message:
    "this computer is no longer authorized to play purchased items that are on the iPhone "Kyle Dixon's iPhone". would you like to authorize this computer for items purchased from the iTunes store? if you do not authorize this computer, 57 items, inlcuding. "xxxx" will be removed from the iPhone."
    i hit the authorize button and the account dialogue box opens. interestingly, it defaults to a .mac account that i havent used in YEARS. so i change it to my current itunes account info and enter the correct password. i then get this dialogue:
    "this computer is already authorized. including this one, you have authorized 3 computers out of your available 5."
    i hit ok...and then i am faced with the exact same dialogue box starting with "this computer is no longer authorized to play purchased items that are on the iPhone "Kyle Dixon's iPhone". and the whole thing goes again.
    all my music plays on my iphone. and most of my music plays on my computer (with it's new logic board) but not all of it.
    any help or suggestions?
    thanks in advance
  2. GeoffG macrumors newbie

    Jan 20, 2009
    I'm having the identical problem with my iPod Touch.
  3. mufflon macrumors 6502

    Sep 15, 2006
    Have you tried re-authencticate your computer on the itunes store?
    It might be connected to which logic board you're using (it got some identifiers after all so might be what apple defines as "the computer")

    You may authenticate 5 computers for any account and if already used up your share of these you can just reset the count (but then you will have to reauthenticate the other computers as well at your leisure)
  4. GeoffG macrumors newbie

    Jan 20, 2009
    It's the authorization loop that it's stuck in. After reauthorizing the computer I am told that it is already authorized. When I dismiss that dialogue box, the original "this computer no longer authorized to play purchased items that are on the iPod... Would you like to authorize?..."
    And the loop goes on (as described in kddpop's original post)............. it then tells me that if not authorized 95 songs will be removed from the iPod.
  5. scottstover macrumors newbie

    Oct 3, 2001
    Sign out, delete, reinstall, sign in.

    I found this to work while nothing else did.
    Store>Sign Out
    Store>Deauthorize Computer

    Delete iTunes app.

    Download and Reinstall iTunes

    Store>Sign In
    Store>Authorize Computer

    Finally, sync phone.
  6. alansmallen macrumors 6502a

    Jun 25, 2007
    Seems risky. I don't want to have to sort through all my music on my mac again....
  7. weeman macrumors 6502

    May 6, 2007
    Success! I was struggling with this stupid problem for a week and this solved it!
  8. dborja macrumors 6502a

    Sep 13, 2007
    Northern California
    I tried this and no joy. iTunes 8.1
  9. Grippy macrumors newbie

    Mar 19, 2009
    I registered because I have the exact same problem with iTunes and my iPod on my new MacBook. It's not a huge deal, as I usually use iTunes and update my iPod with my G4 due to iTunes' habit of putting new music on my local drive and not the assigned network drive.

    Anyway, I deleted my prefs and that didn't work. I took the steps suggested above and that seemed to work, but didn't.

  10. Lucster macrumors newbie

    Mar 20, 2009
    ITunes IPhones stuck in authorization loop


    I had the same problem as well. I spent over 2 hours with 2 Apple technical representatives to fix this issue. I must add that these 2 gentlemen were very patient, polite and knowlegeable. We finally fixed the problem.

    It turns out that some of my IPhone apps were downloaded without inputting my complete user name (the domain name of my email address was not entered).

    This has caused a number of problems after I changed the password on my account. In the end, I had to wipe my Iphone clean and start from scratch. I know that this is not ideal for a lot of people but after trying everything else in the book, this is the only thing that worked.

    I also add to remove the apps that were downloaded with the wrong User ID and download them again. Previously purchased apps can be downloaded for free.

    Basically, you have to reset the IPhone to factory settings. After you connect the IPhone to your computer, go to the IPhone page in Itunes and click on reset. The process takes a while to complete but it will do the trick. If songs or other items cannot be synced after, transfer them to the IPhone manually by dragging.

    Best of luck,

  11. Ginabina61 macrumors newbie

    Aug 21, 2009
    Buffalo, NY
    "computer Not Authorized" Endless Loop

    For those who still experience this problem, I had it after getting my laptop back from the Genius Bar. I did the deauthorize, quit, reinstall itunes thing twice with no success. I finally restored the ipod and that seemed to do the trick, although there are still some songs that itunes tells me are not authorized. Haven't figured that out, but at least I can sync again. This is by far one of the most frustrating problems I have ever had with the Mac.
  12. Brucewl macrumors 6502


    Sep 15, 2010
    The best way to avoid this situation is just authorized on your personal computer...
  13. jaywhy macrumors newbie

    Nov 19, 2007
    This problem happened to me when I synced my iPad after changing my Apple ID password. As long as I used my new password I was stuck in the described loop forever, but when I entered my old password it worked.
  14. Webmason macrumors newbie

    Jan 8, 2009
    Great, now I'm having this problem too... I'll try the above fix and see what happens... :confused:
  15. afj.lambert macrumors newbie

    May 27, 2011
    The Netherlands
    Thanks, this worked for me!
  16. Andrewbanana macrumors newbie

    Sep 16, 2014
    thanks also worked for me in 2014


Share This Page