iTunes and iPhoto Crash! Not working.

Discussion in 'Mac Apps and Mac App Store' started by iLoveDeveloping, May 10, 2010.

  1. iLoveDeveloping macrumors 6502

    Joined:
    Sep 24, 2009
    Location:
    Ireland
    #1
    Ok so 2 days ago i started getting problems with my Mac(10.6.2) (First time like ever!). I tried to start Firefox, it crashed on start up and i mean, it bounced and then NOTHING! I deleted the .plist file and restarted and it worked. Next, iPhoto went down, it wont start at all. Same thing, bounces in the dock and then nothing, not even a start screen.

    I did the same, deleted plist files, even removing and deleting the library (i have all photos backed up so i just wiped the whole thing). I even used "iPhotoLibraryManager" and it didn't do anything, restarted, everything i can think of, still no iPhoto. I googled and googled and found page after page of things that didn't help one bit. Now to be honest i can life without iPhoto, but i NEED to have iTunes, thats not a option.

    So next, iTunes now wont work, (9.1.1) it seems each day a new program is gone! Same as before, i click iTunes icon, it bounces and then dead. I looked up console messages and it is saying (for BOTH iTunes and iPhoto)

    "0x0-0x63063.com.apple.iTunes810 dyld: Library not loaded: /System/Library/PrivateFrameworks/Symbolication.framework/Versions/A/Symbolication" "com.apple.launchd.peruser.50193 (com.apple.ReportCrash817) Job appears to have crashed: Trace/BPT trap"

    So it looks like the libraries are corrupt or something? This seems to be all im getting. Again, i tried rebuilding library, deleting itunes.plist and even deleting the program (and the whole itunes folder) and reinstall a new one from apple, i even made a new user account and logged in and same exact thing, bounce and dead!

    Does anyone know ANYTHING that will help me? I seem to have tried everything!! I am lost without iTunes! Please help... :(:(:(
     
  2. iLoveDeveloping thread starter macrumors 6502

    Joined:
    Sep 24, 2009
    Location:
    Ireland
    #2
    Any ideas? I REALLY need this fixed..
     
  3. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #3
    Simplest thing to do really would be to update to 10.6.3...
    If that doesn't fix it you likely have bad support files for iTunes and iPhoto and may need to reinstall them. iTunes is a free download, make sure you follow the instructions to remove it first, iPhoto will need to be selectively reinstalled from your iLife or Applications Install DVD (disc 2 with new computers).
     

Share This Page