iTunes and New AlumiMac? Are you having problems?

Discussion in 'iMac' started by wpwj40e, Sep 10, 2007.

  1. wpwj40e macrumors regular

    Joined:
    Jan 10, 2006
    #1
    UPDATE:
    Using a hardwired connection will resolve. It is a conflict between airport(wireless) and iTunes. See later post.


    I have been having numerous problems with my new 24" alumiMac - all of which I can trace back to itunes of some sort.

    I have repaired permissions and have deinstalled any 3rd party software. The following are the issues:

    iTunes freezes - usually when broswing store - most times can simply quit and restart. WIll freeze any time I click on two items. As in browsing a music selection then clicking tv shows.

    iTunes freezes and causes entire computer to freeze - turning power on and off "fixes".

    iTunes will not allow ipods to sync - states there are "too many files open", will only do this after going to iTunes store.

    iTunes freezes and next application open - ususally safari - but has been word, iPhoto etc - next click on a different app will cause that app to close with an error.

    Not using iTunes I have no problems.

    Is anyone else having issues? I also have a macbook that is not displaying any of these issues and is running the same iTunes rev.7.4.1.
     
  2. TemeculaMac macrumors regular

    Joined:
    Aug 8, 2007
    #2
    I have a new 20" iMac and use iTunes every day. Fortunately, for me, my mac isn't exhibiting any of the behaviors you describe.

    Sorry...I know that's not what you want to hear, but it works great for me. Hope you can get to the root cause!

    Gary
     
  3. NEiMac macrumors regular

    Joined:
    Aug 13, 2007
    Location:
    THe really dry side of the Pacific NW
    #3
    iMac problems

    Here is a link to several people talking about the same problem. I do believe its a itunes bug of some sort. I do have the same problem, its only when I browse the video section in the iTunes store, for me. If you don't browse the Video part of the iTunes store you probably wont ever know there is a problem. In the link I gave you there has been a couple guys who went into apple stores and recreated the problem on all the iMacs there. One guy went to the Apple store and Best Buy both and recreated the problem on every iMac in both stores twice. Either its a software bug they will fix or Apple is going to have to do a recall or something lol. http://discussions.apple.com/thread.jspa?messageID=5179443&#5179443
     
  4. wpwj40e thread starter macrumors regular

    Joined:
    Jan 10, 2006
    #4
    Thanks for the link!

    For the record I did a clean install and it did not resolve the issues. They are identical. I then called APple support and was told to do numerous installs etc.

    I will take it back to the Apple store this weekend. Not sure what to do as many are having the same issue. But opeing up itunes causes too much havoc and it is one of the apps I use the most, essentially making this iMac unusable!:(

    I am bummed!
    Therese
     
  5. ucfgrad93 macrumors P6

    ucfgrad93

    Joined:
    Aug 17, 2007
    Location:
    Colorado
    #5
    Same with me. No problems using iTunes on my iMac.
     
  6. NEiMac macrumors regular

    Joined:
    Aug 13, 2007
    Location:
    THe really dry side of the Pacific NW
    #6
    Well if you get things fixed let me know. I ordered mine and no Apple Store anywhere near here. So I am not overly excited about returning it. Also from what I read this is a bug in quite a few iMacs, makes me wonder how many of them I am going to have to send back to get a good one. To the two that arent having iTunes problems a couple questions. One have you gone into the movie section of the iTunes store? THis is were everyone has problems if your not going into this section you wont notice it at all, and do you have the new Aluminum Imac? Seeems to be limited to those. I have run hardware test and all kinds of programs this only happens to me in iTunes. I find it hard to believe its something else other then a software bug of some kind. But I have had 3 macs and never seen a program freeze the os like this. THis really is a bummer, it has really ruined the excitement of getting a new Mac. I would of preferred to get one with a cracked screen or something obviously wrong.
     
  7. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #7
    No issues here. I use iTunes everyday for the internet radio and video podcasts and it's never crashed once or affected other programs. My iMac is the new 24" 2.8 Ghz.
     
  8. NEiMac macrumors regular

    Joined:
    Aug 13, 2007
    Location:
    THe really dry side of the Pacific NW
    #8
    Wow, glad you aren't having problems. Thats quite the setup you got. The only thing that isnt different then mine on yours is the graphics card. Mine is a 20" 2GB RAM 320GB HDD with the ATI 2600 HD. Maybe it is hardware. lol
     
  9. dbalone macrumors member

    Joined:
    Aug 13, 2007
    #9
    I have the same problem. For me you must be on the music video page and be scrolling up and down the page. It will freeze it every time. If you just go to that page and do nothing and move on you will not notice anything. Sometimes you have to scroll up and down several times to get it too do it. Apple support does know about this problem. I do not think anyone needs to be taking back there macs. It seems to be only related to iTunes and will hopefully be fixed soon.
     
  10. oduinnin macrumors regular

    Joined:
    Aug 3, 2007
    Location:
    Planet Earth
    #10
    Huh??

    I tried to duplicate this several times with no success. My iMac seems to be working just fine with iTunes since the 7.4.1 update. :)

    Can someone describe in more detail, what you have open, do you have music playing or not when you are "scrolling" one of the iTunes Store pages.
     
  11. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #11
    I think you were referring to me since your post was right under mine. We have the same graphics card but we don't have the same processor. :)
     
  12. tacoma-kyle macrumors newbie

    Joined:
    Jun 9, 2007
  13. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #13
    Wow, it's funny that you mentioned that. I went to the music video section and scrolled and iTunes crashed the whole computer. What I also noticed is that the Ringtones icon was not there after the last update and it was announced this morning that the ringtone feature would be in iTunes.

    I did hard rest (because I had no choice) and then opened up iTunes and the Ringtones icon appeared and now I can scroll in the music video section and no problems at all. In fact all sections of the store are fine for now but I suspect there's a flaw in the OS X version of iTunes. Most likely Apple will address it.

    It's definitely not a problem with the iMac it's iTunes. Most issues with computers is generally the software so there's no reason to take the whole computer back to the store because of one program, that's sort of common sense.
     
  14. wpwj40e thread starter macrumors regular

    Joined:
    Jan 10, 2006
    #14
    Went and re installed again. This time i did a zero erase and then installed OS X again.

    So far everything is working. I did not do a migration and am adding one thing at a time and then checking.

    Did a .mac sync, everything worked fine again. Just added lil snitch and all is still well....

    So...maybe the zeroed our HD with a clean install will do it.

    Gonna keep adding back in my apps and then trying all my ipods. Here's hoping all is well!

    Therese
     
  15. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #15
    What is lil snitch, do you need that for OS X?
     
  16. NEiMac macrumors regular

    Joined:
    Aug 13, 2007
    Location:
    THe really dry side of the Pacific NW
    #16
    Yes thats what I ment, only the graphics card is the same. I think its just a software problem too, been waiting for a fix for seem like forever. I was unfortunate enough to find this bug the first day I got my iMac so its been a long wait. Funny thing is I don't use that part of itunes hardly at all not sure what made me go there. lol Im sure they will make a patch for it eventually.
     
  17. wpwj40e thread starter macrumors regular

    Joined:
    Jan 10, 2006
    #17
    UPDATE:

    I believe I have discovered the problem. There is a conflict with airport (wireless) and iTunes. WHile I have not done any specific skip traces to isolate, it is most defintely between airport in the new iMacs and Itunes (7.4 or 7.4.1) neither release matters.

    Using a direct (lan/wan) via ethernet, there is not an issue.

    I then connected via airport and voila - it rose it's ugly head. I ran a few traces and there is a buffer overun causing havoc.

    To eliminate the possibility it was my carrier (cox), i then took it to a neighbor that uses QWEST DSL - same issue when using airport. ANd finally went down to the apple store, could recreate it every time on their iMacs. Using the iMac's that were hard wired did not present the problem.

    The apple people were...well...I just won't go there. Will provide feedback to Apple and hopefully a software update will resolve.

    In the meantime - for those having the issue - use a hard wired connection if you can, it will go away - also had 5 other folks with the issue test. Hard wired corrected immediately.

    Good luck!
    Therese
     
  18. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #18
    Uh, thanks for the sleuthing but I don't NEED the iTunes music video store so badly that I am willing to give up my wireless until Apple sends a software update.
     
  19. wpwj40e thread starter macrumors regular

    Joined:
    Jan 10, 2006
    #19
    Yea I understand:) The issue is getting cover art - using many of the features will also cause the problem. You may not know it. Given that it is a buffer overflow, what other issues are under the covers will remain "hidden" until a particular file/etc is accessed. iTunes connects to the store about a bazillion times (a little exageration here:))....thats why it was so annoying for me. I do not even buy music from the store! It was all the other connections that were driving me nuts. Short of not using iTunes at all - well...anyways...agree re wireless. I am lucky as my router is on my office desk. Not a big deal...now if this was my macbook - I would be very irritated!

    Therese
     
  20. NEiMac macrumors regular

    Joined:
    Aug 13, 2007
    Location:
    THe really dry side of the Pacific NW
    #20
    Thanks allot!!!! I have been wondering if Airport might be the problem, this makes allot of sense. Think ill just use my Macbook for iTunes, since I wont have internet connection to the macbook if I direct connect the modem to the iMac. Im just so glad it isnt a issue with the iMac itself. Also explains why some people don't have this problem.
     
  21. mzd macrumors 6502a

    Joined:
    Jul 25, 2005
    Location:
    Wisconsin
    #21
    umm, not sure about others, but i tried this tonight and my 24" crashes when i try what the OP suggests in the iTunes Music Video store.
    my airport is off and i'm using an ethernet cable btw.
    also, first crash for my iMac :(
     
  22. oduinnin macrumors regular

    Joined:
    Aug 3, 2007
    Location:
    Planet Earth
    #22
    Must be iMac related

    I finally got it to happen on my iMac by scrolling "vigorously" in the music video section.

    I would suspect it is related to something specific to the new iMac since I spent 20 minutes trying to get it to happen on my MacBook Pro with the same version of iTunes without success (or failure depending on how you view the situation). :(
     
  23. wpwj40e thread starter macrumors regular

    Joined:
    Jan 10, 2006
    #23
    I agree. Only happens with the Imac. with my Imacbook....not a problem.So I agree...It is an issue with the new Imac....

    So only reason I have for those that do not have the issue...make sure you disable airport as it is the default once enabled. If you use wan.lan direct connect does not happen on the new iMac. However, can repeatedly be reproduced on the new iMac with a wireless connection. Not so on the macbook or the macpro or the macpro server. Have many tests now to confirm, there may be other issues causing other problems....but for the ones I was complaining about - very much related to airport and i Tunes...


    Therese
     
  24. HLdan macrumors 603

    HLdan

    Joined:
    Aug 22, 2007
    #24
    I'm not sure it's actually the iMac but rather how the OS X version of iTunes runs on the iMac. I rebooted to Vista via Bootcamp and iTunes runs (dare I say it) perfectly on the Vista side, no crashing in the music video store with excessive scrolling. Sux to see an Apple application (which was originally a Mac only application) have issues on the OS X side on the same computer and run perfectly on the Windows side on the same computer. :eek:
     

Share This Page