iTunes Artwork Problem

Discussion in 'Mac Apps and Mac App Store' started by LukeW, Oct 16, 2011.

  1. LukeW macrumors member

    Joined:
    Nov 14, 2005
    #1
    I'm using the latest iTunes (10.5) on OSX Snow Leopard but I noticed the problem on the previous version of iTunes before I updated. I've got all my music on a 1TB external hard drive and everything was set up correctly and runs smoothly, I can play all my music and add new songs to the library. That is until I try adding artwork to albums/songs/etc.

    Most of the time it is added fine but sometimes it doesn't add it to the file, so if you are going into the Info section of each song, maybe track 1 and 9 will not display anything but a white box while the rest show the shiny new artwork, but the info still says the file was updated at the same time as all the others so where did it go? :confused:

    (I also noticed that occasionally a music track in the Music folder in Finder doesn't have the artwork as a thumbnail, and this doesn't correspond with the former problem. iTunes just seems to have a really bad problem embedding artwork!)

    Is it because I have my iTunes Media folder on a separate hard drive or maybe because I used XLD to rip the music (as Apple Lossless) from my CD collection as apposed to iTunes (which I have found doesn't always produce good results, especially with scuffed CDs).

    Does anyone else have this problem or have any solutions? It's driving the OCD part of me absolutely mad!
     
  2. Grayburn macrumors 68000

    Grayburn

    Joined:
    Jul 12, 2010
    Location:
    London, England

Share This Page