iTunes asking to "accept incoming network connections" every single time

Discussion in 'Mac Apps and Mac App Store' started by Libertine Lush, May 27, 2010.

  1. Libertine Lush macrumors 6502a

    Joined:
    Nov 23, 2009
    #1
    Because I have Firewall enabled, everytime that I launch iTunes, I get a popup asking me: "Do you want the application "iTunes.app" to accept incoming network connections?" I click on "Allow." But unlike other applications where this process is only asked once, the first time you launch an app, I'm asked this every time.

    I've talked with AppleCare about this, and the representative told me it may be because I've disabled "Copy files to iTunes Media folder when adding to library," because I prefer to organize my music folders my own way. She offered 2 work arounds:

    1) Enable file sharing of my Music folder. It didn't work. The prompt still occurs every launch.
    2) Reinstall iTunes. However, admittedly, she said this may not necessarily resolve the issue as it could simply be because I'm not using iTunes' file location by enabling "Copy files to iTunes Media folder when adding to library."

    Does anyone have any idea how to resolve this? Also, if I reinstall iTunes, will I have to re-add my Library to iTunes or are the relevant database/album covers files & folders retained?--it took a few hours for a collection of my size to be added.

    Thank you.
     
  2. MarcusH macrumors newbie

    Joined:
    Oct 14, 2009
    #2
    I have the same problem.

    I have enabled "Copy files to iTunes Media folder when adding to library," - so that might not be the issue.

    Would welcome suggestions.
     
  3. Libertine Lush thread starter macrumors 6502a

    Joined:
    Nov 23, 2009
    #3
    I reluctantly did a reinstall, the last option that seemed completely unrelated. It fixed it. Brought about a different problem. But then fixed that. Almost feel like I'm back on Windows.
     
  4. striker9 macrumors member

    Joined:
    Sep 10, 2008
    #4
    If you go into your firewall, and click on the advanced tab. If you uncheck the "block all incoming connections", you should be able to add iTunes into the allow box.
     
  5. Libertine Lush thread starter macrumors 6502a

    Joined:
    Nov 23, 2009
    #5
    It was already "allowed" in my case.
     
  6. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #6
  7. Kimba macrumors member

    Kimba

    Joined:
    Sep 22, 2009
    Location:
    Ventura County, California
    #7
    I only get this message when I have Home Sharing turned on in iTunes and I've enabled the firewall. So, unless I'm transferring stuff between my MacBook and my PC I keep Home Sharing disabled.
     

Share This Page