iTunes Authorization Problems

ptasker

macrumors newbie
Original poster
Jun 15, 2005
19
0
London
I have recently copied my iTunes library via CD's to from an iMac G5 to my iBook G4. I am using iTunes 7 (but the problem was there in the previous version).

iTunes plays most of the songs on the iBook, but for ones I purchased asks me to authorize the iBook. I understand the 5 machines rule etc. so agree to authorize the iBook to play the songs I have purchased.

I enter Apple ID and Password - All OK.

I get the message "Machine Authorization was Successful - you have authorized a total of 2 machines.."

The problem is, when I go to play one of the songs I still get the message that the computer is not authorized.

I have tried lots of times but am getting nowhere !

Any ideas would be greatly appreciated.

Many thanks
 

rdowns

macrumors Penryn
Jul 11, 2003
27,398
12,409
You can now use your iPod to authorize other computer with iTunes 7. Make sure all purchased songs are on your iPod, plug it into your iBook and right click on it and select update purchased music or something like that.
 

ptasker

macrumors newbie
Original poster
Jun 15, 2005
19
0
London
That did the trick thanks. Still dont know why the traditional method didnt work but its sorted all the same.

Many thanks
 

ericdb92

macrumors newbie
Aug 14, 2008
1
0
I am having a similar problem, I have recently transferred my purchased songs from my ipod to itunes but I can't play them. It asks me to authorize this computer and I have many times. It tells me that it is machine 4 out of 5 so I know its not that. Any ideas?
 

creativedsgn

Guest
Oct 29, 2008
2
0
Authorization problem fixed, try this!

Sign out of your account by clicking on "Store" from the very top menu in iTunes, then selecting "Sign Out". Once you are signed out, click "Store" again and select "Deauthorize Computer". Once you have deauthorized, you'll need to completely quit out of the iTunes program. Then, re-open iTunes and authorize by clicking "Store" and selecting "Authorize Computer".
 

DJY

macrumors 6502a
Dec 20, 2003
843
0
Canberra AUST
Sign out of your account by clicking on "Store" from the very top menu in iTunes, then selecting "Sign Out". Once you are signed out, click "Store" again and select "Deauthorize Computer". Once you have deauthorized, you'll need to completely quit out of the iTunes program. Then, re-open iTunes and authorize by clicking "Store" and selecting "Authorize Computer".
This didn't work for me...
anyone else have any ideas?

I've done this,
deleted SC info folder
checked for the /Users/Shared folder
de-authorised several times and re authorised...

HELP!
 

alansmallen

macrumors 6502a
Jun 25, 2007
859
3
Sign out of your account by clicking on "Store" from the very top menu in iTunes, then selecting "Sign Out". Once you are signed out, click "Store" again and select "Deauthorize Computer". Once you have deauthorized, you'll need to completely quit out of the iTunes program. Then, re-open iTunes and authorize by clicking "Store" and selecting "Authorize Computer".
Having the same problem.
Tried this but no luck.
 

DJY

macrumors 6502a
Dec 20, 2003
843
0
Canberra AUST
What I had to do in the end - which worked...
was to completely delete iTunes...
including all preferences files.

There are easy to follow and simple instructions on the Apple support pages.
http://support.apple.com/kb/HT1224

Then download iTunes - and voila - everything has played since.
 

pdpfilms

macrumors 68020
Jun 29, 2004
2,383
0
Vermontana
Just upgraded to iTunes 9.2 last night, and this morning downloaded some TV shows which I can't seem to get playing. Endless authorization loop.

Have tried updating all software, restarting iTunes, restarting computer, deauthorizing and reauthorizing iTunes, verifying account info assigned to episodes, signing out and then into iTunes store, fully deleting iTunes (following apple support document) and reinstalling.

Still can only get a grey screen for each of the episodes, none of them play normally. However, all other iTunes-acquired content plays fine.

Advice? Apple support has yet to respond.
 

Chrisip

macrumors newbie
Jul 1, 2010
1
0
Just upgraded to iTunes 9.2 last night, and this morning downloaded some TV shows which I can't seem to get playing. Endless authorization loop.

Have tried updating all software, restarting iTunes, restarting computer, deauthorizing and reauthorizing iTunes, verifying account info assigned to episodes, signing out and then into iTunes store, fully deleting iTunes (following apple support document) and reinstalling.

Still can only get a grey screen for each of the episodes, none of them play normally. However, all other iTunes-acquired content plays fine.

Advice? Apple support has yet to respond.
I am having the exact same problem and I have tried all of the above also.
 

bellapotter16

macrumors newbie
Aug 8, 2010
1
0
Please Help Me If You Can!

my Ipod is jailbroken and every time i try to load an app it crashes. i've tried syncing my Ipod and updating the apps but with no results. does anyone have any idea what i can do to fix this problem? i heard it was an authorization problem but i dont know....