iTunes Authorization

timmillwood

macrumors 6502a
Original poster
Apr 7, 2006
957
1
When i go onto my iTunes to play a song i have bought it asks for my username and password.

Once this is entered it tells me " you have authorized a total of 4 machines out of your available 5" when i have only 3 machines.

I click ok and then get an error message "There was an error storing your authorization information on this computer. The required directory was not found or has a permissions error. Correct the permissions problem and try again, or de-authorize this computer if the permissions cannot be changed."

I have repaired permissions using "Disk Utility" and i have de-authorized and tried again. Neither have worked.

Any ideas?

P.S it is only one out of my three computers this is happening on, the other two are fine.
 

timmillwood

macrumors 6502a
Original poster
Apr 7, 2006
957
1
mad jew said:
You've tried everything I can think of except this. It shouldn't apply to current versions of iTunes but maybe have a look through it all the same. :)
Didn't work... What am I going to do!!

I want to buy some more music, but I won't be able to listen to it
 

PlaceofDis

macrumors Core
Jan 6, 2004
19,239
4
perhaps its time to send an email to the iTunesMS tech support staff explaining your problem, it could be an issue on their end perhaps. its really an odd thing for this to happen, they might have a better way to sort things out.
 

timmillwood

macrumors 6502a
Original poster
Apr 7, 2006
957
1
tried contacting iTunes Music store and they are sorry about my problem but only deal with non-technical problems
 

Cooknn

macrumors 68020
Aug 23, 2003
2,111
0
Fort Myers, FL
I had a message come up saying that I had already authorized 5 computers. I guess it was from when I set up new Mac's for friends. It's easy enough to de-authorize all of them, then just authorize the Mac that you want to use. You'll have 4 left after that as well. As far as the error, not sure. Maybe that will fix the problem...