iTunes auto downloading music...how do I make it stop??

Discussion in 'Mac Apps and Mac App Store' started by SnarkyBear, Oct 21, 2015.

  1. SnarkyBear, Oct 21, 2015
    Last edited: Oct 21, 2015

    SnarkyBear macrumors member

    SnarkyBear

    Joined:
    Apr 24, 2014
    #1
    I have a lot of purchased songs from the iTunes store that I do not want downloaded--songs that I bought for my wife or son, or that I have outgrown.

    Today when I opened up iTunes, I noticed it was auto downloading my music library. I went through preferences, but I could not find where to make it stop. Under "Automatic Downloads" I have unchecked the Music, Movies, TV Shows, and Apps buttons, but it is still downloading my entire library.

    HALP!

    UPDATE: We updated to 12.3.1 this morning, and I am speculating that is the source of the problem.
     
  2. mgroot macrumors regular

    mgroot

    Joined:
    Jul 25, 2014
    #2
    Did you restart iTunes since changing that setting?
     
  3. SnarkyBear thread starter macrumors member

    SnarkyBear

    Joined:
    Apr 24, 2014
    #3
    I did not change the settings; those were the settings I had. I did quit and restart iTunes several times, but to no avail.
     
  4. SnarkyBear thread starter macrumors member

    SnarkyBear

    Joined:
    Apr 24, 2014
    #4
    Found the problem...The "Show Apple Music" button was rechecked after updating iTunes, and somehow it determined that I needed to redownload everything. After unchecking said box, iTunes is behaving again.
     

Share This Page