iTunes automatically launches when audio downloaded in Safari?

Discussion in 'OS X Mavericks (10.9)' started by ArtOfWarfare, Oct 5, 2013.

  1. ArtOfWarfare, Oct 5, 2013
    Last edited: Oct 5, 2013

    ArtOfWarfare macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #1
    I just downloaded several audio files in Safari (some .mp3, some .wav) and found that each time one finished, iTunes would launch on its own and play it.

    I looked through the Safari and iTunes preferences, and the System Preferences, but couldn't find anything relevant. This is an incredibly annoying behavior - how do I stop it from occurring? I only listen to music using Spotify (and I generally just use QuickLook to preview sound effects)... I only use iTunes to move files between my iMac and iPhone - were it not for that, I'd uninstall iTunes entirely.

    Also checked Finder preferences. Still nothing. Sending a request to the author of Tinker Tool to see if he could add something that changes this.
     
  2. matthewadams macrumors regular

    Joined:
    Dec 6, 2012
    #2
    Look closer ;-)

    First page on Safari Prefs on the very bottom.
    "Open "Safe" Files after downloading".

    Actually looked for that myself just right now after seeing your post cause I found it quite annoying, too.
     
  3. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
  4. ArtOfWarfare, Oct 5, 2013
    Last edited: Oct 5, 2013

    ArtOfWarfare thread starter macrumors 604

    ArtOfWarfare

    Joined:
    Nov 26, 2007
    #4
    Thanks!

    So I guess the only reason iTunes is opening, then, is because there's file associations going on. I wonder if I can assign Finder to handle audio files instead...

    Edit: Okay, I tried that, and I recommend you don't try that as it caused Finder to behave very erratically. Anytime I clicked off of the Finder window it would force itself back in front of whatever other window I clicked on. All I had to do was change iTunes back to be the application that handles audio. Guess I'll just uncheck that box in Safari preferences.
     

Share This Page