iTunes automatically plays movies through Apple TV, how to stop it?

Discussion in 'macOS' started by TheBaconKing, Feb 4, 2011.

  1. TheBaconKing macrumors regular

    TheBaconKing

    Joined:
    Dec 2, 2010
    Location:
    Northwest Arkansas
    #1
    Somehow I managed to turn something on through the Apple TV or iTunes and cannot for the life of me figure out how to fix it. Whenever start any video in itunes it automatically connects to one of my two Apple TVs in the house and plays it through the Apple TV. I do not want it to do this anymore.
     
  2. dXTC macrumors 68020

    dXTC

    Joined:
    Oct 30, 2006
    Location:
    Up, up in my studio, studio
    #2
    Check to see that you haven't accidentally activated AirPlay in iTunes. Look at your iTunes window. At the bottom right is an icon with a large rectangle, and a triangle pointing into it; this is the AirPlay icon. Click it, and you should see some choices. One is Computer; the others should be your Apple TVs. Make sure the Apple TVs are unchecked, and that the Computer one is the only one checked.
     
  3. TheBaconKing thread starter macrumors regular

    TheBaconKing

    Joined:
    Dec 2, 2010
    Location:
    Northwest Arkansas
    #3
    it is never connected to any Apple TV until I start a movie. Music plays just fine through the computer too.

    I have gone through all the settings I could think of on both the Apple TV and in iTunes, and have had no luck. It is more of a nuisance than anything as I usually just have to switch it to the other Apple TV or to my computer after I press play.

    I probably should have mentioned this in the first post, but it automatically connects to the same Apple TV. Never does it auto connect to the main one in the Living room, just the one in the Bedroom.
     
  4. mcjake1971 macrumors newbie

    Joined:
    May 25, 2011
    #4
    Same Problem

    I got the same problem. I start a movie in iTunes. Instead of playing the movie on the computer screen, it sends the movie over to Apple TV. I click on the triangle on the bottom of iTunes to switch it to the computer. When I quite the movie and play it again or click to watch a new movie it sends it back to Apple TV again. How do I stop it from automatically sending the movie to apple TV through airplay?
     
  5. timcuthbert macrumors newbie

    Joined:
    Jul 8, 2011
    #5
    I also have the same issue, everytime I start a movie, tv show, vid cast on my Mac it starts on the AppleTV. I check Airplay is only set to the computer, but as soon as it starts it changes to be the AppleTV.
     
  6. timcuthbert macrumors newbie

    Joined:
    Jul 8, 2011
    #6
    Solution..

    To any and all still experiencing this issue, just click on the little AirPlay symbol in the bottom right of the iTunes window and click on 'Multiple Speakers'; then check your AirPlay speaker that iTunes is automatically using, and then uncheck it! Simple.

    Now it should work perfectly!
     
  7. footloose, Aug 17, 2013
    Last edited: Aug 17, 2013

    footloose macrumors newbie

    Joined:
    Aug 17, 2013
    #7
    Solution

    Hi,
    New Here regarding iTunes automatically plays movies through Apple TV, how to stop it? Running Mac OS iTunes 11.0.4 in iTunes select edit and select all right click on any media icon and select get info select options place a checkmark in the media type and click ok done. Hope this helps and don't forget to register macrumors!
     

Share This Page