iTunes broken, can't restore from TM

Discussion in 'Mac OS X Lion (10.7)' started by Rhei, Aug 2, 2012.

  1. Rhei, Aug 2, 2012
    Last edited: Aug 2, 2012

    Rhei macrumors member

    May 16, 2011
    Hello folks. So awhile ago my HD went caput and I had to replace it. I could still operate my laptop, and during this time I attempted to access iTunes. Lo and behold I couldn't, and I thought this was just due to the HD failing. Fast forward a bit, I've replaced my HD with a Momentus XT750, Super Duper cloned everything fine, except my iTunes is still acting up. Here are the steps I've taken to rectify the situation:

    1) Restore iTunes from TM to a time before my HD was failing. Result: Unable to do so, iTunes is an integral part of OSX and cannot be modified or deleted.

    2) Downloaded iTunes straight from apple website and installed. Result: Same issue. iTunes errors out and will not open.

    3) Tried to create a new library with iTunes. Result: Same issue.

    4) Booted to safe mode and tried to open iTunes. Result: Same issue.

    5) Restored iTunes from TM to desktop and tried to copy over into applications. Result: Unable to modify iTunes.

    I've tried just about everything I can think of short of a clean install. I haven't yet scheduled a Genius Appt (am I able to do this for free even though my MBP is out of warranty?) So I'm coming here for some insight before I move on. I appreciate any help that can be offered.

    Edit: Apparently I can't post the error report as it's too long, so I've printed it out to PDF and put it up in my dropbox. Not sure of any better way for doing this. It can be found here: Error Report.pdf
  2. Rhei thread starter macrumors member

    May 16, 2011
    As an update, I just thought about restoring permissions and attempted it. Still didn't do anything. Just in case that's something that someone may suggest.
  3. plinden macrumors 68040


    Apr 8, 2004
    You can't delete iTunes from Finder, but you should be able to from the command line.

    Open Terminal and type: sudo rm -rf /Applications/

    Then reinstall from the downloaded dmg.

    If this doesn't work, you might have to do a clean install and migrate your data and apps from your SuperDuper clone.
  4. robgendreau macrumors 68040

    Jul 13, 2008
    Is iTunes working at all, in other words, can you start it up, access the store, etc?

    Have you opened it (i.e. started it up) by using option-double click and tried creating a new library that way? I'd also try trashing iTunes prefs, restarting, and trying to open it. Make sure that the iTunes folder is somewhere iTunes won't see it and automatically try to open it, or use option to create a new library.

    This first step is to see if iTunes itself works, and then next see if your library can be repaired. Odds are the hard drive crash wrecked it.

    There are instructions on how to do that here:

    You could also try to use migration assistant instead of restoring; restoring tries to set it up anew. You essentially want a NEW library but with as much of your data as possible.
  5. Rhei thread starter macrumors member

    May 16, 2011
    Thanks for the replies.

    Plinden: Did what you suggested, but to no avail. Thanks for the suggestion.

    robgendreau: I've already attempted to create a new iTunes library, and even did what Plinden suggested. Removed the old iTunes, downloaded a fresh one, reinstalled and tried to create a new library. The issue is that the option to do any of that does not even show, the icon just bounces a few times then crashes. There was one time where I managed to get the option to create new library or search for a library. I pointed it to my old library and again no luck. I haven't had this option come up again.

    I think I'm going to make a genius bar appointment. Not sure how much they can actually help, but we'll see. Thanks for the attempts.
  6. Rhei thread starter macrumors member

    May 16, 2011
    Just an update. Here at the Apple store now. They've tried a lot of the same stuff and repairing permissions from their own boot drive with no success, looks like a hard drive format is in the works. Thanks again to the two of you for trying to help out.

Share This Page