iTunes Can Not Save Library

Discussion in 'Mac Apps and Mac App Store' started by hexonxonx, Jun 6, 2013.

  1. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #1
    At least twice a day, I get the warning that the iTunes library can not be saved.

    Ok. In the past, all I had to do was close iTunes and restart the app.

    Now when I close iTunes after this happens and i Reopen it, I get the warning that the application can not be opened. The only way to reopen it is to reboot the computer. I'm getting so upset with this that often times, I'm just holding the power button to turn it off quickly instead of getting a stupid warning that mail prevented the computer from shutting down o some other app.

    This is on a 2010 MB running ML with all current update. This also happens on a 2008 black MB with SL and all updates.

    I've tried moving the .itl files from the external drive to the MBs internal drive and that does not help on either computer.

    The 2010 MB has a fresh install on ML and this still happened with all updates.

    There has got to be a fix for this, please help. iTunes is my main use for both of my computers.
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    The problem might be permissions, go to the iTunes folder and get info on it, also on the folder inside that folder, don't go deeper, it will take too much time, look if the right permissions are set, you need Read/Write access.
     
  3. hexonxonx thread starter macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #3
    It showed read/write for me but I also changed it for every option there to read/write.
     
  4. justperry, Jun 6, 2013
    Last edited: Jun 6, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    I didn't tell you in my last post but the easiest way to change that folders permissions to R/W for all (safe to gave everybody the right, just music) is to open terminal and enter:

    sudo chmod -R 777 then a space behind the x and drag the folder there, hit enter and password, that's it, The Folder and all it's contents is R/W for all.

    Edit: I changed the command above, forgot chown and changed to numeral, it works!
     

Share This Page