iTunes cannot read the contents of the iPhone

Discussion in 'Jailbreaks and iOS Hacks' started by ilyaa1, Dec 25, 2007.

  1. ilyaa1 macrumors newbie

    Joined:
    Oct 13, 2004
    Location:
    Delaware
    #1
    Hello

    As of today, I've suddenly started receiving this message when trying to connect my iPhone to iTunes: "iTunes cannot read the contents of the iPhone ^1. Do to the Summary tab in iPhone preferences and click Restore to restore this iPhone to factory settings." I've uninstalled all the recent programs and updates from the Installer and did a hard reset. I've tried two different cables, and installed iTunes on another PC with a fresh Windows install. Still, the same problem occurs under all combinations. Must add that the phone was working perfectly before today, and that despite the PC connection problem, all other features on the iPhone itself are working fine.

    Now, taking the iPhone to Apple would involve finding someone to take it over Atlantic and hand it over to my friends from NYC who bought it for me, so I'm trying to postpone this option.

    The problem that I have is this. This is an unlocked jail-broke iPhone with firmware 1.1.1 (anySIM software used). Restoring the iPhone through iTunes apparently involves installing 1.1.2, for which no unlock is yet available. Plus, I'm not sure if doing a restore on an unlocked iPhone is a good idea.

    Does anyone have any kind of comments on this? Is there anything I can do get a fully-functional unlocked iPhone without having to ship it overseas?

    Thanks a lot in advance.
     
  2. viet.dunker macrumors newbie

    Joined:
    Nov 14, 2007
    #2
    Why don't you try craiglist if you guys have it there.
     
  3. ilyaa1 thread starter macrumors newbie

    Joined:
    Oct 13, 2004
    Location:
    Delaware
    #3
    well, the point is not to find someone to ship the phone, but to find the solution to the problem...
     
  4. viet.dunker macrumors newbie

    Joined:
    Nov 14, 2007
    #4
    like I said find your local iphone hacker in craiglist.

    Meet face to face as to fix the phone.

    I wouldn't ship out my iphone at any chance.

    I don't trust those service that require you to ship out and stuff except for Apples.
     
  5. Templex macrumors regular

    Joined:
    Jul 12, 2007
    Location:
    Los Angeles, CA
    #5
    It's only not possible to unlock your iPhone if it came with 1.1.2. Upgrading to 1.1.2 isn't a problem, though. Revirginize your baseband, use OktoPrep, upgrade to 1.1.2, use jailbreak.jar, then use anySIM 1.2.1u (with airplane mode on -- this is important).
     
  6. ilyaa1 thread starter macrumors newbie

    Joined:
    Oct 13, 2004
    Location:
    Delaware
    #6
    Templex, thank you, will try it today. If that fails - gonna just have to get it over Atlantic to fix it under warranty.
     
  7. brando88 macrumors 6502

    Joined:
    Nov 13, 2007
    #7
    Download the 1.1.1 restore file here: http://www.modmyifone.com/forums/downloads.php?do=file&id=1355

    and restore in iTunes back to 1.1.1 by holding Option (mac) or Shift (PC) and clicking on restore, and then navigating the the restore file that you just downloaded.

    Make sure the restore file ends in .ipsw, if its .ipsw.zip, delete the .zip

    (it's just no fun looking for these files haha, i thought I'd tell you where to look.)
     
  8. aszmhodeus macrumors newbie

    Joined:
    Jan 1, 2008
    #8
    Hello.

    Did this method work after all? I`m having the same problem.

    Thanks!
     
  9. sweetdreamsbudd macrumors newbie

    Joined:
    Jan 24, 2008
    #9
    Itunes cannot read the content of the IPhone

    Hey i have a similar problem, but for 1.02// What happened was that i was syncing then i disconnected it and after that, Itunes wouldn't work. it keeps showing that darned message.

    I have a v.2.63 dled from Nullriver and it's jailbreaked, so i know that i don't have the choice of a restore settings... What do i do?!?!

    Also from a 2.63 i'm unable to switch to a 3.0b because "Size of file mismatch" PLEASE help
     
  10. Niclariv macrumors newbie

    Joined:
    Dec 17, 2009
    #10
    The solution, summarized

    This assumes that your phone is already jailbroken (I wonder if anyone who has a non-jailbroken phone ever experiences this problem?).

    1) On a Mac using Cyberduck or a PC using WinSCP, view the files on your iPhone (google SSH Cyberduck iPhone if you need help with this step)

    2) Navigate to /private/var/mobile/Media/iTunes_Control/iTunes/
    and delete the file iTunesDB

    At this point, iTunes will no longer give you the error message BUT, your music, ringtones, podcasts will still be taking up space on your iPhone but your iPhone won't try to read them and iTunes won't see them. The solution is the next step.

    3) In Cyberduck (or WinSCP) navigate to /private/var/mobile/Media/iTunes_Control/Music and delete all of the folders in the Music directory

    4) Go back one level to /private/var/mobile/Media and go to the Ringtones directory and delete them too.

    5) Close iTunes and open it again, allow your iPhone to sync again. It should copy all your music, podcasts, and videos back to your phone, though depending on how much you have, it could take a while.

    6) If you have Ringtones in your iTunes and they're not going back on your phone after all of this, plug your phone in and select the iPhone in Devices in iTunes and click the Ringtones tab. Deselect 'sync ringtones' and it will display a message warning you that all ringtones will be removed from you phone. Accept that and click 'apply'. After the phone has finished syncing, select 'Sync Ringtones' again and click apply. Allow it to sync. That successfully put the ringtones back on my phone.

    I did this on March 6th 2010 on a Jailbroken 3G 16 gig running the 3.1.2 OS and it worked fine. Good luck with your own phones, I hope this works for you and I summarized the instructions clearly enough.
     
  11. marmelle macrumors newbie

    Joined:
    Mar 30, 2010
    #11
    Niclariv

    Thanks for the tip. It did allow itunes to actually see the iphone.

    But, As it was doing its initial set-up synchro did fail.:mad:

    It says that "required file cannot be found".
    "unknown error (-6999).
    It also strangely only sees 4Go of capacity where I do have a 16G V1-US iphone

    (V1-US - 3.1.3 - Jailbreak Redsn0w + unlock)
    Any further clue on what I should do ?
     
  12. wfenwick macrumors newbie

    Joined:
    Sep 15, 2010
    #12
    What finally worked for me...

    Tried the steps outlined by Niclariv, no go.
    Tried resetting the settings on the phone, no go.
    Have tried this phone on different usb ports, and on mac/WinXP, no go.

    What finally did the trick, after all of the above attempts, was finding this tip:
    http://www.everythingicafe.com/foru...unes-error-it-was-just-the-begining-5320.html

    Post #8, indicated to delete iTunesCDB.

    So now I'm back in business.

    And for the record, I'm running on a 3gs (old bootrom) with 4.0 firmware.
     
  13. newrazr macrumors member

    Joined:
    Aug 8, 2010
    #13
    Easy solution

    I had the exact same problem and posted on this last week. Here's the link to my post. Go to the last item in the thread for what worked
     
  14. EiriniR11 macrumors newbie

    Joined:
    Dec 18, 2010
    #14
    It works!!

    Had the same problem, itunes could not read the contents of the iphone, so I tried what you suggested and deleted the "itunesDB" file using the iphone Explorer and it worked instantly!! I am so happy! Thank you guys so much!!
     
  15. drlex2k macrumors newbie

    Joined:
    Jan 3, 2011
    #15
    Excellent

    Dude, you are the man!!!
    It worked for me. I saved myself from rejailbreak!!!:)
    Just another tip. In my case i couldn't use ssh because my cydia is crashing to and i couldn't install ssh on the iphone. The good thing is that ia had installed a local term and that way i could delete the files!!

     
  16. elfben macrumors newbie

    Joined:
    Oct 20, 2011
    #16
    Problem Solved

    I had the same problem (itunes not reading my phone) on my new (to me) unlocked Iphone 3gs running 4.3.3 with an at&t goPhone sim

    I don't have wifi at home so I used the FREE iexplorer
    (http://www.macroplant.com/iexplorer/) to browse my iphone and deleted the files and folders described in this thread and now iTunes syncs perfectly! THANK YOU!!!

    Success on October 20, 2011
    iTunes 10.2.1
    iPhone 3gs 32GB (unlocked) running 4.3.3 (8J2)
    with At&t GoPhone Sim
     

Share This Page