iTunes can't find iPhone after attempted 2.0.1 update

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Nikklaus, Aug 15, 2008.

  1. Nikklaus macrumors member

    Joined:
    Aug 9, 2007
    #1
    Hi all,

    I've been trying to update my iPhone 3g to 2.0.1 for a week now. Every time I click 'update' it starts extrating the software and then I get an error message (code: -19) and it drops back to iTunes. I tried again today after completing an hour long backup and I got a bit further. iTunes started 'preparing' my iPhone for the update, my iPhone screen started displaying an image of a USB cable and the iTunes logo, seemingly prompting me to connect, and then it failed. But my iPhone is still displaying that image and now iTunes won't recognise it at all. I've tried turning it off and on several times, but its still bricked. :(

    Anybody else had this - and how can I fix it? At this point I'd be happy simply restoring to factory settings, but my iPhone is either permanently displaying this image or switched off. Absolutely no response from iTunes.

    Thanks
     
  2. ajthomason macrumors 6502

    #2
    That is really odd, I've just had the same problem on my fathers iPhone 3G, well a similar one at least. Trying to update it to 2.0.1 sent it to an endless "connect to iTunes" phase (it happened just at the point of 'Preparing iPhone for software update' came on the screen). After trying everything, the only way I could restore it was to plug it into my laptop...

    Plugging it into his didn't even get it to show up, just as yours is doing. My laptop is a MBP, his is a PowerBook G4 if that makes and difference. It may have just been that it was his laptop that caused the problem.

    Either way, my advice is to find someone else's Mac or PC and restore it from there, it should recognise it fine.

    It's really odd that you're having the same problem. I only managed to get it to restore 5 mins ago.
     
  3. Snakeyeskm macrumors newbie

    Joined:
    Jul 29, 2008
  4. Nikklaus thread starter macrumors member

    Joined:
    Aug 9, 2007
    #4
    Thanks guys, managed to fix this by connecting to a friend's iTunes.
     

Share This Page