Itunes can't find my songs!

Discussion in 'Mac Apps and Mac App Store' started by sophie8, Oct 10, 2009.

  1. sophie8 macrumors newbie

    Joined:
    Jul 31, 2009
    #1
    I have spent a whole week importing songs from my external hdd to Itunes (ordering, adding album art, deleting double songs etc.) Almost 230 GB on music! Since I have a 500 GB hdd, I decided to deselect 'copy files to Itunes media folder' under preferences. I have a backup on my external hdd and I didn't know for sure if I would get the songs double (one in Itunes library and one in Itunes music folder, so taking up more space. I assumed that I could do this, since I read in 'Itunes help' that I could also deselect this option if you have your files stored on an external hdd.

    While I was doing that my external hdd was connected to my laptop all the time. Today I finally finish the job, deconnected the hdd and found out that Itunes can't find any of my songs back! Only when I connect the external hdd to my laptop I can play the music.

    Is there a way to solve this problem or do I need to do it all over again while making a copy from my files to Itunes media folder? Since Itunes couldn't find any of my songs, I assume that for examply a 100 mb album will take up 100 mb on my hdd on my laptop and not 200MB?

    Then there's a second problem: I deleted one of the albums in Itunes and imported the album again, but this time I selected the checkbox 'copy to itunes mediafolder when adding to library'. But now my songs are showing up double! One has the extension mp3 and the other one 1.mp3

    When I go to Itunes mediafolder they show up there twice, so they don't show up in two separate folders.

    If I need to import all the songs again and delete the doubles manually it will take me ages, so if someone could help me out I will be so thankful!!!!

    Thanks a lot!
     
  2. instaxgirl macrumors 65816

    instaxgirl

    Joined:
    Mar 11, 2009
    Location:
    Edinburgh, UK
    #2
    If by iTunes library you're referring to the actual list of songs you see when you open iTunes the files aren't actually stored there. Normally if you don't deselect the 'copy files to Itunes media folder' button the files are all added to the iTunes music folder. iTunes then plays the songs from there.

    However, since you told iTunes not to copy your music to the media folder the library is simply linked to wherever each music file is on your HD. (this is actually how I run my library as I don't have space on my internal)

    Basically when that option is selected you do not end up with the files doubled. You would have ended up with 2 copies of each music file though because you back up - one on your internal HD in the media folder and the back up on your external HD. You would not have ended up with the 2 copies of the files on your internal HD though.

    Therefore as you've found out you are unable to run your library without your external being connected because iTunes has not actually copied the files to your internal HD, it's just linked to them on your external.

    I'd probably delete all the song from the library within iTunes (don't touch any of the actual files on your external) check the "copy to iTunes media folder" box and then just drag and drop all the files from your external. I think since you've added album art to them all now that should all be embedded and should just reimport. Mine has all its album art, lyrics etc embedded in the original mp3 files now. Try it with one album and see what happens.

    It will take a while though since that 230GB of music will need to be copied to the iTunes folder on your internal drive as well as being imported into iTunes and it will take ages.

    However, if you've been deleting doubles within iTunes then unfortunately they will still be on your external. Unless you've been seeing the little box which asks if you want to delete the song from iTunes and the original file. If you've been getting that dialogue and telling it to delete the original file then it'll be gone, otherwise the doubles will still be there.

    There is a trick to get iTunes to show you all your doubles though. I can't remember it but google should bring it up.


    This is because you do now have doubles in your library. You have the files on your external and now you've got them on the internal too.

    Hang about a bit and see if someone can suggest you a more elegant way to do things than just reimporting the whole lot again because you are dealing with A LOT of data. There might be a more straight forward way that I'm not thinking of.
     
  3. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #3
    When you added files from the external drive to your library, iTunes records where those files are located. If you disconnect the external drive, of course iTunes can't find them! How can iTunes access data on a drive that isn't connected? If you want that music accessible with the external drive disconnected, you have to copy that music to your internal drive.

    If you select the "Copy files to iTunes Music folder when adding to library" option, of course iTunes will make a copy of your music. That's the purpose of that function.

    First, decide whether you want to manage your music files, or if you want iTunes to do that. If you decide to manage files yourself, decide whether you want them on an external drive (which you can only access with the drive connected) or on your internal drive, or both.
     

Share This Page