iTunes changed file kind, killed artwork

mcgarry

macrumors 6502a
Original poster
Oct 19, 2004
616
0
Sorry if this has been posted already-- I searched first, to no avail.

The most recent* update of iTunes has created an unfortunate problem for me. All mp3 files in my library are now identified (under "Kind") as "QuickTime movie file." The file name in the path under "Where" still says .mp3, however.

In so doing, iTunes now no longer displays any of the album art I had attached to the mp3s! The tags aren't there any more.

Most of my collection is aac, admittedly, but this stinks. Am I missing something, or is this just a Great New Feature?

* there's a slight chance this started with 4.8, but definitely not before that, and I am pretty sure it came with 4.9
 

mcgarry

macrumors 6502a
Original poster
Oct 19, 2004
616
0
Mechcozmo said:
Easy, I think. Try changing the filetype to "Open with iTunes"

Maybe?
Thanks for the tip ... but no, that didn't work. They were already set to open with iTunes, and re-setting didn't help.

Interestingly, I have found that what I said above was not exactly right: mp3s I ripped using iTunes work correctly, mp3s created using anything else do not-- but they all worked in every version of iTunes I used, until this latest one.
 

Mitthrawnuruodo

Moderator emeritus
Mar 10, 2004
13,602
145
Bergen, Norway
MacOSXHints had a tip about this the other day...

Edit: Having Developer Tools, I just tried using the /Developer/Tools/SetFile (after first getting a valid type and creator from a functioning file using /Developer/Tools/GetFileInfo):

$ /Developer/Tools/SetFile -t "docu" -c "macs" /path/to/song/filename.mp3

Now that song works just fine... :)