iTunes confused

Discussion in 'Mac Apps and Mac App Store' started by steve1960, Apr 29, 2015.

  1. steve1960 macrumors member

    Joined:
    Sep 23, 2014
    Location:
    Singapore
    #1
    So, I have confused myself and iTunes. It's my own fault, too many changes at one time!

    Bought a late 2013 15" rMBP with a 512GB SSD to replace the old 2011 model. Took the 512GB out and put in a 1TB, transferred the 512GB to my wife's 2013 MBA.

    No issues at all with the hardware changes, installing Yosemite or adding back in programs and Apps. However, iTunes seems a little confused. Family sharing is switched on.

    When I tried to install the recent Apple updates for Keynote, Garage Band etc on my wife's MBA it would not accept my wife's iTunes sign in details or mine saying the MBA was not authorized for these programs and I would have to buy them. However, despite this pop up message appearing every time I tried to install each of the five upgrades iTunes went off and updated them anyway. Any suggestions for fixing this? I can't do 'update all' when there are multiple updates I have to do them individually and with the pop up box each time telling me the MBA is not authorized.

    When I tried to synch my daughters iPad using the rMBP I could not choose manually the home videos I wanted, iTunes just refused to update the iPad. I disconnected, powered off the iPad and powered on again after which iTunes did update the home video selection but it also added all of the icons for the 100 movies we have bought through iTunes. It shows them as being ready to download from the cloud. This just confuses my 4 year old as she can't understand why all the movies are not there to watch! How do I remove all the cloud icons?
     
  2. Pharmscott, Apr 29, 2015
    Last edited: Apr 29, 2015

    Pharmscott macrumors 6502a

    Pharmscott

    Joined:
    Dec 13, 2011
    Location:
    Sacramento, CA
    #2
    For the first issue, just deauthorize all computers then reauthorize the ones you actually use/need. This should only take a few minutes and will solve the problem.

    To remove the cloud icons, go to Preferences, then the Store tab and uncheck "Show iTunes in the Cloud Purchases."
     
  3. steve1960 thread starter macrumors member

    Joined:
    Sep 23, 2014
    Location:
    Singapore
    #3
    First issue, done that let's see what happens the next time the operating system wants to upgrade an App.

    Second issue, that was already unchecked, I tried checking it and unchecking again. No difference the iCloud purchases still show on the iPad :-(

    The wonders of iTunes......................
     
  4. Pharmscott macrumors 6502a

    Pharmscott

    Joined:
    Dec 13, 2011
    Location:
    Sacramento, CA
    #4
    Aha, also an easy fix. I thought you were just trying to hide them in iTunes. To hide them on an iOS device, go to Settings, Music, then deselect "Show All Music" to hide the iCloud items. Repeat in the Videos section if you want to hide those too.
     

Share This Page