iTunes: Converting to AAC cuts track time short

Discussion in 'Mac Basics and Help' started by The.316, May 29, 2014.

  1. The.316 macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #1
    I added an album to my iTunes, and when I click either all the songs in the album, or each song individually, and click convert to AAC, iTunes is making each track the same length as the first song of the album. The first song is 3:37, it converts it to AAC, at 3:36, then the rest of the songs from the album are 3:36 as well. And its only doing it to this latest album I loaded. I tried other songs in my library, and they are all converting fine. Anyone have any suggestions as to what the heck is going on?
     
  2. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #2
    If you're converting from another compressed format such as MP3, you're only decreasing the sound quality by encoding to another compressed format
     
  3. The.316 thread starter macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #3
    I already have everything as AAC already, and I dont really want to have different file types.
     
  4. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #4
    Not real clear but are you saying...

    Import a CD into iTunes and it makes all songs the same time length as the 1st song on the CD.

    So tracks on CD are....

    1- 3:37 (3:37 is probably correct and the same as 3:36 due to rounding)
    2- 4:54
    3- 2:45
    4- 5:27.....

    ....and you are getting imported into iTunes you get...

    1- 3:36
    2- 3:36
    3- 3:36
    4- 3:36.....

    If so is all the other meta data correct?
     
  5. The.316 thread starter macrumors 65816

    The.316

    Joined:
    Jul 14, 2010
    Location:
    25100 GR
    #5
    That is exactly right.

    I am importing Coldplays new CD. Here is what it looks like after converting the first four tracks:

    [​IMG]

    All the times are the same. If I choose a track I already have, and convert it to AAC, it is converting it properly.
     
  6. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #6
    Actually it looks like you have an MP3 imported and are then transcoding the MP3 to AAC. Are you importing an MP3 from your CD first and then transcoding to AAC???? If so then this is a BIG no, no and will result in loss of audio quality. It may also be corrupting the metadata. Start with your CD and directly import to AAC.

    Do you have some need for a MP3 version? If so you would be ether off importing to ALAC and the transcoding to MP3 or AAC as needed.
     
  7. duozmo macrumors newbie

    Joined:
    Jul 16, 2006
    #7
    Re-encode the MP3s

    Hit the same problem as OP.

    I found a workaround, at least for my case. I re-encoded all of the files with LAME 3.99.5 with VBR turned off. iTunes converted those MP3s to AAC just fine.

    If you're comfortable with the command line, you can install LAME via Homebrew. Then, execute with:
    Code:
    lame -h -V 0 in.mp3 out.mp3
    Repeat for each track, or use your ninja shell-fu to do them all at once.

    In defense of OP's question: Bugs in the conversion process to AAC are important, because iTunes converts music to AAC before loading onto iPhone. Also, let's just assume he has his reasons for doing the conversion. Any loss of sound quality is going to be minor, and is no reason to ignore this issue.
     

    Attached Files:

  8. YanniDepp macrumors 6502

    YanniDepp

    Joined:
    Dec 10, 2008
    #8
    I've also had this issue when converting files or copying them to iDevices.

    Converting them through LAME does seem to work, but the version I use (in an Ubuntu VM) seems to strip metatag data out.
     
  9. duozmo macrumors newbie

    Joined:
    Jul 16, 2006
    #9
    YanniDepp, I would play with your LAME settings. I had no loss of metadata. Even the cover art survived.
     

Share This Page