iTunes crashes after new HDD and Time Machine restore?

Discussion in 'macOS' started by HaveBlue83., Mar 1, 2015.

  1. HaveBlue83. macrumors newbie

    Joined:
    Mar 1, 2015
    #1
    NOTE:i forgot my old PW and email changed, so I had to create a new name as well, sorry!)

    OS: 10.6.8 snow leopard.

    I just successfully installed a new HDD (Toshiba 500gb) into my 3,1 late 2007 macbook. The apple one atom bombed in dec. I went to the apple store and they FireWired OS 10.6.8 into the HDD and I restored using my Time Machine backup file I had from last year. I DID have to redo the login PW throught the old Boot CD and reset my password option as well. Everything is good except itunes.

    I tried to open iTunes and it crashed, something about no image, I was on 11.0.4. I JUST deleted that and tried the 11.4 iTunes (newest for pre 10.7 I could find), and it STILL crashes:

    Process: iTunes [2106]
    Path: /Applications/iTunes.app/Contents/MacOS/iTunes
    Identifier: com.apple.iTunes
    Version: ??? (???)
    Build Info: iTunes-1140011004000018~1
    Code Type: X86 (Native)
    Parent Process: launchd [137]


    Date/Time: 2015-03-01 23:18:17.357 -0500
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6


    Interval Since Last Report: 6484 sec
    Crashes Since Last Report: 633
    Per-App Crashes Since Last Report: 9
    Anonymous UUID: EBB96743-9084-4C20-8F0F-AB4C351FB5FE


    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0


    Dyld Error Message:
    Library not loaded: /System/Library/Frameworks/CoreMedia.framework/Versions/A/CoreMedia
    Referenced from: /System/Library/PrivateFrameworks/AVFoundationCF.framework/Versions/A/AVFoundationCF
    Reason: image not found


    Binary Images:
    0x8fe00000 - 0x8fe4163b dyld 132.1 (???) <4CDE4F04-0DD6-224E-ACE5-3C06E169A801> /usr/lib/dyld


    Model: MacBook3,1, BootROM MB31.008E.B02, 2 processors, Intel Core 2 Duo, 2.2 GHz, 4 GB, SMC 1.24f3
    Graphics: Intel GMA X3100, GMA X3100, Built-In, 144 MB
    Memory Module: global_name
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x88), Broadcom BCM43xx 1.0 (5.10.131.42.4)
    Bluetooth: Version 2.4.5f3, 2 service, 19 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: TOSHIBA MQ01ABD050, 465.76 GB
    Parallel ATA Device: HL-DT-ST DVDRW GSA-S10N
    USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8501, 0xfd400000 / 3
    USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0229, 0x5d200000 / 3
    USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x5d100000 / 2
    USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8205, 0x1a100000 / 2



    ANY INFO? I just wanted to keep using the laptop for my ipod syncing and web surfing, with the new HDD I have more room for songs. I cannot update to 1.07 as far as I know.

    Brit.
     
  2. HaveBlue83. thread starter macrumors newbie

    Joined:
    Mar 1, 2015
    #2
    anyone have any advice? I still cannot use iTunes.
     
  3. Bomb Bloke macrumors regular

    Bomb Bloke

    Joined:
    Feb 12, 2015
    Location:
    Tasmania (AU)
    #3
    Any particular reason Snow Leopard was installed over firewire? Why wasn't your Time Machine backup restored as a single step? When you restored your data from the backup, did you do so as a system restore, or did you use Migration Assistant?

    See, the error is typical of what happens when you attempt to open an iTunes library in an older version of iTunes than what it was last successfully used with.

    For example, if you hold Option when launching iTunes, it'll give you the, um, option to make a new library (or switch to any of your existing libraries). Give that a go - does iTunes open with a new one?
     

Share This Page